Automated Scripting

Advertisement

istbshj
Joined:
Posts:
1
Location:
United Arab Emirates

Automated Scripting

Dear Team,
We have an automated script running and recently we have been getting an error message for Time stamp while the batch file has finished executing and all files are transferred to the remote directory.
It was not there before and there are no changes done. While doing it manually it shows the same and we need to press skip all.
open sftp://xxx/ -hostkey="ssh-rsa xxxxx"
synchronize remote \\server\Company\TalabatISTNB -nopermissions -resumesupport=off -delete -criteria=<none> -nopreservetime /talabat-prod-nfvsftp-eu-west-2/istanbul
exit

Please help.

Description: Timestamp error.

Error Timestamp.JPG

Script Error.JPG

Reply with quote E-mail

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
40,538
Location:
Prague, Czechia

Re: Automated Scripting

Your console screenshots shows completely different error that what you claim to get. So what problem/error do you need a help with?

Reply with quote

Guest

autoated scripting

Dear Martin,
I am having trouble with a batch file I recently posted. When I run the script with the criteria size, there are no issues. However, if I keep the same criteria and there are changes after one hour or manually, the file does not move and shows no synchronization. The same file synchronizes the changes when I log in directly through WinSCP. Additionally, if I change the criteria to time or none in the same script and make changes to three files, only one file synchronizes and returns an error showing "abort skip all," which I underlined with a blue circle. What could be causing this issue with size happening but other options returning errors? It shows timestamp errors.
Please suggest any changes

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
40,538
Location:
Prague, Czechia

Re: autoated scripting

I understood that with time or none the script always transfers one file and fails on the second one with "The process cannot access the file because it is being used by another process." – Did you try to check what process uses the file?

I do not understand uder what circumstances do you get the "timestamp errors". Can you explain? Are you referring to the "Upload of file ... was successful..."? Did you check Upload of file .. was successful, but error occurred while setting the permissions and/or timestamp. If the problem persists, turn off setting permissions or preserving timestamp. Alternatively you can turn on ‘Ignore permission errors’ option.

Reply with quote

Advertisement

You can post new topics in this forum