Cannot set permissions when using S3

Advertisement

kaidean
Joined:
Posts:
1
Location:
UK

Cannot set permissions when using S3

First, let me preface this with saying I am a Mac user but I have to use a PC for certain aspects of my job, I am not a very proficient PC user. We have an S3 AWS server which I am uploading to. I have created the bucket and uploaded the files all fine. On my Mac I use Transmit, in there I simply right click the directory and change the Read and Write permissions to 'World', job done.

I cannot for the life of me find a way to do the same with WinSCP. I seem to be able to set the permissions on a file (not dir) by file basis but this takes ages and mostly does not work.

I thnk I saw somewhere that the permissions need to be set when I create the directory but the option to do that is greyed out.

Is there a way I can do what I am asking?

Thanks

Kai

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
40,837
Location:
Prague, Czechia

Re: Cannot set permissions when using S3

Indeed, WinSCP currently does not support setting S3 ACL recursively.
Can you be more specific about the "mostly does not work" part?

Reply with quote

Advertisement

You can post new topics in this forum