Receiving Reply 1004 to Command 4

Advertisement

connor.dawson
Joined:
Posts:
2

Receiving Reply 1004 to Command 4

Hi,

I'm using WinSCP 6.1.2.13797 command line to automate the process of backing up content from my Azure FTP server. I do this via a PowerShell script using the command:
& "C:\Program Files (x86)\WinSCP\WinSCP.com" `
    /log="$WinSCPLog" /loglevel=2 /logsize=6*1500M /ini=nul `
    /command `
    "option batch on" `
    "open ftps://<user>:<password>@<server>" `
    "cd /" `
    "lcd $CurrentMonthDirectory" `
    "synchronize local -delete -preservetime LogFiles LogFiles" `
    "synchronize local -delete -preservetime site site" `
    "synchronize local -delete -preservetime data data" `
    "exit"
I intermittently receive this response causing the WinSCP command to exit:
Got reply 1004 to command 4
Are there any suggestions to what may be causing this? Are there any ways to improve my script to account for this and continue the backup?

Thank you

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
40,291
Location:
Prague, Czechia

Re: Receiving Reply 1004 to Command 4

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, use /log=C:\path\to\winscp.log command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

connor.dawson
Joined:
Posts:
2

Re: Receiving Reply 1004 to Command 4

Hi Martin,

Our log generated by the process is about 5 GB total, 375 MB compressed. I took the tail end of the log and have attached it here.

Is there anything you're looking for specifically? Should I provide a different part of the log?

Thanks

Reply with quote

martin
Site Admin
martin avatar

Re: Receiving Reply 1004 to Command 4

I does not look like the "Got reply 1004 to the command 4" is an error in the case. It is just a log entry.

What exactly did you mean when you wrote "receive this response"? Where/how did you receive it?

Reply with quote

Advertisement

You can post new topics in this forum