INI file defaults to "Automatic INI file" after each restart

Advertisement

pashakagan
Customer
Joined:
Posts:
7

INI file defaults to "Automatic INI file" after each restart

Hello,
I've been using the same synced INI file on two computers for several years now.
Lately I noticed that one of the instances doesn't show the updated sites.

After checking, I managed to figure out that on that PC, WinSCP always defaults to "Automatic INI file" instead of staying on "Custom INI file" in storage settings.

How can I rectify this and make sure that my 2nd installation respects the custom file?

This is a recent issue, been working like this for years now.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
40,567
Location:
Prague, Czechia

Re: Ini file defaults to "Automatic INI file" after each restart

So you:
  1. start WinSCP (how exactly?)
  2. go to Storage preferences
  3. set the Custom INI file
  4. close WinSCP
  5. start WinSCP again immediately
  6. configuration storage is on "Automatic INI file"
Is that exactly, what you are doing?
I assume, you have portable WinSCP, not installed one, right?
Does the "Automatic INI file" exist after 4.? Does the "Custom INI file" exist after 4.? Does HKCU\Software\Martin Prikryl\WinSCP 2 Override registry key exist after 4.? Does its IniFile value point to the correct path? What version of WinSCP are you using? Is it the latest one?

Reply with quote

pashakagan
Customer
Joined:
Posts:
7

Hey,
Thanks for writing back!
Just to clarify – I use the Windows Store version, which I purchased a while ago. So, not a portable configuration – but an installed version with a shared INI configuration.
It did work flawlessly until recently. Not sure when it happened.

Also, I don't have Martin Prikryl under HKCU\Software. I have found the key in multiple locations in the registry – all seemingly MS Store related.

I launch the app by hitting the Windows key and typing – then hitting Enter when WinSCP is highlighted. I find it most comfortable for MS Store apps.

The process you described is correct. I open WinSCP, go to storage config, set the INI, restart when prompted – it relaunches and still points to the default/automatic location.

Reply with quote

martin
Site Admin
martin avatar

So you select an existing custom INI file. On the prompt, you select Use. WinSCP restarts on its own (you do not restart it yourself). And after restart, you are back to [/i]Automatic INI file[/i]?

Reply with quote

Advertisement

pashakagan
Customer
Joined:
Posts:
7

Haven't tried regular – as I said, it's recent, started happening few weeks ago, and I've been using the store version for few years now.

I can try reinstalling. Any particular protocol you'd like me to follow? I.e. have both versions installed at the same time, uninstalling the store version first, deleting a folder/registry key, whatever.

My hunch is that a reinstallation will solve this, but then I'll also lose the ability to recreate this bug :)

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
40,567
Location:
Prague, Czechia

Sorry for my late answer, I've missed your post.
Debugging the Store installation is tricky.
I've tried to add some logging to narrow down the problem:
https://github.com/winscp/winscp/commit/16935d8d840427547e455503753d601506aa2f89
While I can send you a pre-release build, it cannot be installed over the official installation. You would have to uninstall it. But as you fear that reinstallation might "solve" the problem... :) we might have to wait for the next release before proceeding.

Meanwhile, I've found out how to access the sandboxed registry of Store installation:
How to use RegEdit utility to see Virtual Registry for a Win32 UWP app
Can you try using the Hover tool mentioned there to check the HKCU\Software\Martin Prikryl\WinSCP 2 Override registry key mentioned in my first post above?
The "MSIX" package to look for in the tool is "MartinPikryl.WinSCP_tvv458r3h9r5m".

Reply with quote

pashakagan
Customer
Joined:
Posts:
7

I'm "afraid" the bug resolved itself after I tested with the regular WinSCP.
After having installed it and later removed it, the MS store version behaves like it should now and retains the settings INI file.

My wild guess is that some registry setting got overwritten, thus solving the problem.

Thanks for the assistance, sorry we couldn't get to the root cause :)

Reply with quote

Advertisement

Advertisement

You can post new topics in this forum