TLS error with version 6.3.3

Advertisement

h.o.veiser@4sale-it.de
Donor
Joined:
Posts:
7
Location:
Germany

TLS error with version 6.3.3

Hi,
with the client WinSCP.exe on the command line I try to connect to a server using SFTP.
The data connection over TLS is failing with:
234 AUTH command ok. Expecting TLS Negotiation.
SSL3 alert write: fatal: protocol version
error:0A000102:SSL routines::unsupported protocol
unsupported protocol
TLS connect: error in error
On the client side we are using Windows 2022 with TLS 1.3/2
Using the GUI the error is the same.
Some weeks ago it was working and other SFTP-programs are working too.
Any idea?

Reply with quote

Advertisement

h.o.veiser@4sale-it.de
Donor
Joined:
Posts:
7
Location:
Germany

Re: Re: TLS error with version 6.3.3

Thank you and sorry to be unclear.
Here is the command line:
"C:\Program Files\PuTTY\psftp.exe" -batch -v -bc -pw "Password" -b "c:\Rechnungsimport\Scripts\ftp_Kommandos.lst" user@xy.de >> D:\Rechnungsimport\ueberwachteDir\XY.log
In the configuration it says "Explizites TLS/SSL".

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
40,984
Location:
Prague, Czechia

Re: Re: TLS error with version 6.3.3

It is even more unclear to me now.
What does the psftp commandline have to do with WinSCP?
Anyway, psftp is an SFTP client. Not an FTP client. The SFTP has nothing to do with TLS/SSL.
If the SFTP works, use the SFTP in WinSCP, not the FTP.

Reply with quote

h.o.veiser@4sale-it.de
Donor
Joined:
Posts:
7
Location:
Germany

Re: Re: Re: TLS error with version 6.3.3

Sorry, you are right,
this was the second example with PuTTY, which does not work either.
Using SFTP the log looks like this:
Failed to connect to 1.0.0.0: Network error: Connection timed out
Knocking FTP port.
FTP port opened, will suggest using FTP protocol.
FileZilla is working with FTP and explicit TLS.

Reply with quote

Advertisement

Guest

Its feels like you're still confusing SFTP with FTPS and that feels like the actual problem based on what I see. All your comments seem to be mixing both SSH and FTP encrypted :)

Reply with quote

h.o.veiser@4sale-it.de
Donor
Joined:
Posts:
7
Location:
Germany

Re: Re: Re: TLS error with version 6.3.3

May be I am wrong, my understanding is, that we have a server which is looking for a FTP request over TLS.
The Log error says it would not support SSL3.
What can I do to force WinSCP to use at minimum TLS 1.0?
If I use FileZilla it is using TLS 1.0 whithout problems.
Thank you

Reply with quote

Advertisement

martin
Site Admin
martin avatar

Re: Re: Re: TLS error with version 6.3.3

Thanks. Though, please enable Debug level logging in FileZilla (Edit > Settings > Debug).

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
40,984
Location:
Prague, Czechia

Re: Re: Re: TLS error with version 6.3.3

FileZilla uses obsolete TLS 1.0 with your server, probably because the server is NOT updated to support modern security protocols.
WinSCP does not allow TLS 1.0 by default for security reasons. But it can be configured to do so:
https://winscp.net/eng/docs/ui_login_tls
Though you should update the server, instead of using obsolete protocols.

Reply with quote

h.o.veiser@4sale-it.de
Donor
Joined:
Posts:
7
Location:
Germany

Re: Re: Re: TLS error with version 6.3.3

Thank you very much Martin,
that was exactly the problem.
The error is somewhat missleading, but you have got it!
It is now working as expected.
By the way, we have no access to the server and have already ask serveral times to update it.
Have a nice day!
Hans-Otto

Reply with quote

Advertisement

martin
Site Admin
martin avatar

Re: Re: Re: TLS error with version 6.3.3

I'm sending you an email with a development version of WinSCP to the address you have used to register on this forum.

Reply with quote

Advertisement

You can post new topics in this forum