Topic "Include wild card * not grabbing appropriate files/folders"

Author Message
QSS
[View user's profile]

Joined: 2006-06-02
Posts: 7
Location: Albuqeurque
I am using winscp 3.8.1

I have written a couple scripts using syncronize and the exclude function but i am having trouble with an include and I have even tried it in the gui.

I have some sub directories that start with QSS that need to be syncronized to my ssh server. My script is the following:

option include "C:\GCRMC Studies\*\QSS*","C:\GCRMC Studies\*\QSS*\*"

synchronize remote "C:\GCRMC Studies" "/home/GCRMC/QSS Inbox"


I have used a similar exclude command on my server when doing a sync local and it works fine, but when i am trying to use it on my local machine TO the server it does not grab the sub directories and their files and upload them. Instead it finds no differences when in actuality the server does not even have the QSS sub directory that i am trying to upload.

My initial idea is that there is some bug or problem with using multiple wildcards * for the local computer. It seems like if i run a test include with just one wildcard it will work but when i try to use two wildcards in different directories it finds no differences. Very strange.

Thanks in advance
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24991
Location: Prague, Czechia
I'm afraid that WinSCP does not support quoted masks. You can try something like:
Code:
option include C:\GCRMC?Studies\*\QSS*,C:\GCRMC?Studies\*\QSS*\*
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License