Error creating temp directory by external editor

Advertisement

sak2104
Joined:
Posts:
3

Error creating temp directory by external editor

Hi,
I made an honest attempt to find and answer for this problem on the forum, but couldn't. I open two files in a row by an external editor (Matlab). Files are on the remote directory. The first file is fine, it allows me to save changes. The second file cannot save changes, because - I checked - the temp directory it refers to is not created! Why this may happen?

thank you

Sergei

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Error creating temp directory by external editor

How do you open the files? Do you use Open or Edit command? If Open, configure the matlab as an external editor for WinSCP, make sure you check External editor opens multiple files in one window and use Edit command.
_________________
Martin Prikryl

Reply with quote

sak2104
Joined:
Posts:
3

I set Matlab as external editor, and now I have no problems editing multiple files and saving them. However, the problem appeared when I used Open. I prefer to use internal editor for general purposes and edit Matlab files using Open command. What could be the problem? As I said, it fails to create a directory. I went to preferences, all reasonable boxes are checked.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

sak2104 wrote:

I set Matlab as external editor, and now I have no problems editing multiple files and saving them. However, the problem appeared when I used Open. I prefer to use internal editor for general purposes and edit Matlab files using Open command. What could be the problem? As I said, it fails to create a directory. I went to preferences, all reasonable boxes are checked.
Please read documentation for explanation of your problem. You can associate Matlab for with specific extension only and use internal editor for all other file types.

Reply with quote

filip_scm@...
Guest

I had the same problem and it has a very easy fix

When you open the files do not hit Enter, edit them by pressing F4 !!!
That is it :).

Reply with quote

Advertisement

You can post new topics in this forum