Scripting synchronize with filesize criteria

Advertisement

gina
Guest

Scripting synchronize with filesize criteria

Hi Martin:

How are you?

Here is my question:

When scripting /synchronize, does it check the filesize criteria (as in de GUI)?

I have a problem where a sync to remote from a Win XP to a Redhat Fedora 5 is not synchronizing, alltough even filesizes differ.

Thanks for your support.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Scripting synchronize with filesize criteria

Do you actually mean scripting or /synchronize command-line option?
_________________
Martin Prikryl

Reply with quote

gina
Guest

Yes, sorry, I mean scripting:

winscp3.com /command "synchronize remote ..."

I'm using a ini file with /ini=<file>. In the ini file I defined CompareByTime=1, but it seems not to work.

Any advice?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

In scripting you cannot synchronize by time. Moreover CompareByTime option is for "compare directories" function.
_________________
Martin Prikryl

Reply with quote

gina
Guest

Compare by size

Oops...And can I use "CompareBySize=1" when scripting?
Does it have any effect?

IMO, it is very usefull to force a sync when file size differs.
At least, when synchronizing in one way.

Could you add this feature in a next release?

As said before, I have two machines. When I edit a file in the machine 1 and do a sync from machine 1 to 2, the file is not uplodad, so I have to connect via SSH and remove the file first in order to get it uploaded. This is very annoying.

Thanks.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Compare by size

I can add this in the next release.
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Compare by size

Is this working now?
Yes. Please read documentation. If that does not help, come back.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum