Problem with connection

Advertisement

clientvoip
Joined:
Posts:
4

Problem with connection

Hi,

I have written my first script, but he doesn't work correctly.
The script run on Windows XP PC, I want connect to remote machine (with Fedora 5.0)

The script is:
option batch on
option confirm off
open root@IP_addr_Fedora_machine
pwd
ls
close
exit

From an open console windows, I write
winscp3.com /console /C:\Document and Setting\user\Desktop\script=scriptSCP3.scp

The script ask me user name, I specified it and the output is

HOST DOESN NOT EXIST

Could someone help me?

Thanks in advance

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,802
Location:
Prague, Czechia

Re: Problem with connection

clientvoip wrote:

winscp3.com /console /C:\Document and Setting\user\Desktop\script=scriptSCP3.scp
This looks strange. Should it be:
winscp3.com /console /script=C:\Document and Setting\user\Desktop\scriptSCP3.scp

Reply with quote

chessys
Guest

User Name prompt

I am also being asked for a "user name" when using the /command line. Here is my batch file...

option batch on
option confirm off
open name@host.com
cd /home/exportfiles/
option transfer binary
put D:\*
exit

Here is my command line...

"C:\Program Files\WinSCP3\WinSCP3.com" /console /script= D:\Exportfiles.txt

The open command is set for a stored session however I tried to use the name:password@host option with the same results. I'm successfully using a similiar batch file but using the "get" command instead of "put" and with the same saved session.

Thanks in advance for assistance.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,802
Location:
Prague, Czechia

Re: User Name prompt

chessys wrote:

I am also being asked for a "user name" when using the /command line. Here is my batch file...

option batch on
option confirm off
open name@host.com
cd /home/exportfiles/
option transfer binary
put D:\*
exit

Here is my command line...

"C:\Program Files\WinSCP3\WinSCP3.com" /console /script= D:\Exportfiles.txt

The open command is set for a stored session however I tried to use the name:password@host option with the same results. I'm successfully using a similiar batch file but using the "get" command instead of "put" and with the same saved session.

Thanks in advance for assistance.
So with "get" you are not prompted for password?
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum