Topic "crash when trying to edit specific file"

Author Message
Orion
[View user's profile]

Joined: 2006-12-23
Posts: 2
Location: NL
WinSCP always worked great for me, until today.

When trying to open a certain remote file 'aux.hpp' (by pressing F4), winSCP just hung up on me. It never did this before. So I cropped and touched it to be reborn empty, restart WinSCP etc - same crash. Hmm, should the name of the file be the cause? Tried it on another aux.hpp on another place - same crash. Variations on this theme: crashes on aux.cpp and aux.test, but NOT on aux2.ext (all empty dummy files, just for the bug hunt). Do the programmers feel no-one (else) should use any aux.*?! Smile

Details:
* version 3.8.2 (build 330)
* logging mode: debug 2 (sample crash logfile (<invalid hyperlink removed by admin>))
* SFTP (v3)
* Norton Commander-style interface
* No error message! WinSCP initiates the copy to local temporary directory, it seems to finish ok, then the dialog disappears and the program just hangs.
* Taken steps with above logfile:
- login
- scroll down in home dir
- select aux.cpp and press F4 to edit. crash.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
Aux.* files are not allowed on Windows (try that yourself). And WinSCP does not handle that properly. I'll try to fix it.
Orion
[View user's profile]

Joined: 2006-12-23
Posts: 2
Location: NL
Ah, I see (the retardedness of Windows, that is Wink...). More reserved words: https://en.wikipedia.org/wiki/Filename

A possible solution for WinSCP would be to add a hash to the temporary local filename. But I guess you already have something similar or even better in mind.
Thanks anyway!
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License