no real background transfer possible and winSCP crashes!



no real background transfer possible and winSCP crashes!


I think this behaviour should be caused by one or more bugs within winSCP:

I tried to use winSCP under windows XP with all service packs and newest putty to download a 1GB file from a pc that has a dial-in connection to the internet.

Unfortunatly the dial-in connection (DSL) of the TARGET-pc is VERY unstable at the moment --> every few MINUTES the dial-in-connection is separated and re-established --> with a NEW IP (I use dyndns with a TTL of 60 seconds).

So this setup is a VERY GOOD test environment for your resume feature :-)

I installed the newest version 3.8.2. I use a keyfile to authenticate.
I use the following Settings:
Interface Style: Norton
Supported Protocols... hmmm:

SSH protocol version = SSH-2
SSH implementation = OpenSSH_4.4
Encryption algorithm = aes
Compression = No
File transfer protocol = SFTP (v3)
Server host key fingerprint
ssh-rsa 1024 6c:68:99:3d:12:78:84:b6:23:a5:0d:94:87:d8:fa:50
Can change permissions = Yes
Can change owner/group = No
Can execute arbitrary command = No
Can create symlink/hardlink = Yes/No
Can lookup user groups = No
Can duplicate remote files = No
Can check available space = No
Native text (ASCII) mode transfers = No
Additional protocol information
The server does not support any SFTP extension.

Files above 100KB
Automatically reconnect after 7 seconds
1 Max. Transfer
x Transfer on background by default
x No confirmation for background transfers when idle
x Automatically popup prompts of background ...
(x means this option is checked/set)

And no confirmation on "Transfer Resume".

I get a QUERY:
Host has not answered for 15 seconds.
Wait another 15 seconds?
Abort Retry
If I ignore this window, the download seemed to continue after a while.

But at some point (I assume, when the dial-in connection of the target-pc is lost again) I get a little error message:

Network connection reset by peer
OK Reconnect

If I IGNORE this message, then it works: winscp tries again and again and at some point gets new connection and continues the download.

BUT if I press OK here:
The download/logged-in/session window CLOSES and
WinSCP is back at the login screen (session-manager-screen)!

And an little error message window appears:

Invalid access to memory

Then the program flickers for about half a minute and then it closes/crashes!!!


Now I unset the "Automatically popup prompts of background transfers when idle" option and now it seems to work without interruption... NO!

There is the "?" blinking and "Query" written in the "Progress"-column for the active job.

But why does the "automatically popup prompts of background transfers when idle" apply to this case?
Because the background transfer was not idle. It was simply interrupted. There is/was still a lot more to transfer (both: of this one big file and there where further jobs in the queue)?

Back to what happened / what I did:
I had to click "show query" and I got this message again:
Host has not answered for 15 seconds.
Wait another 15 seconds?
Abort Retry
Then I had to select "Abort" so that it continued!
The next time the connection was lost I got FIRST the message:

Network connection reset by peer
OK Reconnect
I waited and little later the Query "?" was blinking again for this job!
I tried to deal with the query (and to ignore the "reset by peer" error message) but this was not possible, so I clicked on "Reconnect". It reconnected. Then I waited and after I thought, that winSCP does NOT resume automatically, I double clicked on the job to pop-up the query-window, but in this moment the download resumed and "connecting" appeared in the "progress"-column for this job and the query-window that shortly popped-up vanished.

On the next connection-lost it was again only the Query "?" blinking and it does NOT continue, if I don't react to it (again I ONLY needed to simply double-click on it... then shortly the query-message-window appeared and vanished again and the download continued)!?
Is this logical? ;-)

And unfortunatly this is not "non-interactive" ... winSCP is lacking an option:
"try x times to retry and then abort"
"aort (and reconnect) after "x" seconds (or "y" retries)
"always reconnect"

And what about this "Reset by peer" message?!
Sometimes it appears, sometimes not, but as far as I understand it, it is always the same: the target pc gets disconnected from the internet and directly redials and updates dyndns and is about 10 seonds later up and available (by ping or ssh) again.

This "reset by peer" window should not appear for backround-transfers, or?
And the query should be answered automatically so that it continues, if I tell him to transfer in background.
And why does the option "popup ... when idle" apply to my case, even if the download queue was full?


Finally a little suggestion of improvement:
2 more checkbox-options:
Alt+F4 minizes instead of closing winSCP?
minmize to systray (with overall progress indication in the systray-icon)

I would use only the upper one.
Like this I could use ALT+TAB to bring winSCP form time to time to front to see the progress.
And could easily minimize the window to queue it like this at the TAIL of the Alt-Tab-window-list.
What do you think?

Greetings and a good start for 2007,


Reply with quote


You can post new topics in this forum