Topic "File permissions / umask"

Author Message
Guest




I've tried to set up the remote side to use umask 002 (which would make all new files have 664-permissions) but I have no success. If I look in the Terminal window of WinSCP I have the correct umask but when I upload a file it gets 644-permissions.

It seems that WinSCP doesn't care about if I have "Set permissions" checked or not - if have changed the permissions (to 604 for example) and uncheck "Set permissions" an uploaded file will get 604-permissions anyway.

I have tried with version 2.3.0.

Thanks in advance!

Daniel Andersson
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Anonymous wrote:
It seems that WinSCP doesn't care about if I have "Set permissions" checked or not - if have changed the permissions (to 604 for example) and uncheck "Set permissions" an uploaded file will get 604-permissions anyway.

It cares. Please post a log file.

For me 'umask' works if I set it in '.bashrc'.
_________________
Martin Prikryl
Guest




prikryl wrote:
It cares. Please post a log file.

Sorry for beeing stubborn but I made the test again from another computer (see the log file). In the first case, I have Set Permissions unchecked (but you can see the permissions "below" set at 644). In the second case, I have Set Permissions checked (and permissions set to 644). In both cases, umask is 002.

You will find the log file at <invalid link removed>. It was to long to post here, in my opinion.

prikryl wrote:
For me 'umask' works if I set it in '.bashrc'.

For me too, as well as in .bash_profile (according to the termial window) but to no avail.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Anonymous wrote:
Sorry for beeing stubborn but I made the test again from another computer (see the log file). In the first case, I have Set Permissions unchecked (but you can see the permissions "below" set at 644). In the second case, I have Set Permissions checked (and permissions set to 644). In both cases, umask is 002.

Well, the test with 644 permissions (default one) is not relevant. It is natural that whether you check "set permissions" or not, file rights would be always 644. Please try again with another permissions.

Anonymous wrote:
For me too, as well as in .bash_profile (according to the termial window) but to no avail.

I've meant that if I set umask in '.bashrc' and use bash shell, umask works even with WinSCP.
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License