files copied to temp directory but not target directory

Advertisement

vince100
Guest

files copied to temp directory but not target directory

I am using version 3.8.2 build 300, "Norton Commander" interface, Use temp directory for drag & drop.

The problem is that sometimes when I transfer large amount of files by dragging the remote folder onto my windows (XP) desktop, the files will be copied to the temp folder but NOT my desktop. The transfer dialog just closed and the Explorer copy dialog never appeared. The problem can happen with any remote servers and any local Explorer folders. It seems somehow winscp just forgot to do this very last step.

The problem has been haunting me since 2.x version. It has never been solved. And with the latest version, things just became worse: I used to be able to manually browse to the temp folder and get my files there, but with the latest version, winscp seems to be pretty confident in what it is doing and always delete the temp folder even if the files are NOT copied to the target folder at all. Maybe at least do a checking in the code: if files are in the target folder then delete temp dir?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,562
Location:
Prague, Czechia

Re: files copied to temp directory but not target directory

vince100 wrote:

The problem is that sometimes when I transfer large amount of files by dragging the remote folder onto my windows (XP) desktop, the files will be copied to the temp folder but NOT my desktop. The transfer dialog just closed and the Explorer copy dialog never appeared. The problem can happen with any remote servers and any local Explorer folders. It seems somehow winscp just forgot to do this very last step.
Is it possible that it happens when transfer takes too long time?

Maybe at least do a checking in the code: if files are in the target folder then delete temp dir?
If WinSCP could know what's the target folder, it would not need to download the files to temp dir first :-(
_________________
Martin Prikryl

Reply with quote

vince100
Guest

Yes, it did take a long time to transfer the files before that happened. Is that a problem? I can transfer without the temp folder, but then i cannot drag between two remote servers. :( Since the final copy was done by windows explorer, is that a communication problem between winscp and explorer?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,562
Location:
Prague, Czechia

vince100 wrote:

Since the final copy was done by windows explorer, is that a communication problem between winscp and explorer?
I guess that Explorer simply gives up waiting for WinSCP to deliver files.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum