terminal protocol documentation

Advertisement

guest
Guest

terminal protocol documentation

I'm trying to setup a server to be able to allow users to use the Files->Custom Commands->Disk Space Usage

The problem is I don't want to give full bash access to the users. I have a program that appears to give correct responses to winscp however winscp just hangs and eventually gives this error

Host has not answer for 15 seconds


I've tried reading the source code but my C is pretty weak and i get lost before i can understand it. I'm probably just not sending a non printing charater it expects but any help would be appreciated.

Reply with quote

Advertisement

Guest

just so you understand what i'm talking about I get the following input
echo "WinSCP: this is end-of-file:0"
and i then print the following on stdout
WinSCP: this is end-of-file:0
i have tried with \n and \r\n and \n\r as end of line. winscp always hangs and my program gets no further input from winscp

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,809
Location:
Prague, Czechia

Please post a log file.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum