Network error: connection refused

Advertisement

florianne
Joined:
Posts:
1
Location:
FRANCE - Paris

Network error: connection refused

Hello
I hope that somebody will help me to solve this problem:

With my personnal PC, I cannot get connected to the server hosting my website. I always get this error message:"Network error: connection refused". I don't know who refuses the connection: the server or my PC. I tried to connect to this server with two others PC (using sames data : password, user name, ..) and it works!!
So I think that my PC have a problem : is a programm or a software missing, or is it something about a virus, or just some options which are not correct matched?

Thanks for any help

Reply with quote

Advertisement

Shaman
Guest

same problem

Same problem here. It only has problems when I use a server with SSH, FTP works fine. Btw I use Vista Ultimate.

Reply with quote

Sooner Al
Joined:
Posts:
10
Location:
Norman, Oklahoma

Re: same problem

Shaman wrote:

Same problem here. It only has problems when I use a server with SSH, FTP works fine. Btw I use Vista Ultimate.

Are you running a SSH server on your Vista Ultimate PC or is the Vista Ultimate PC the SSH client? That is not clear to me...

Is the server behind a firewall?

Are the appropriate ports open on the firewall, ie. the default SSH server listening port is TCP Port 22?

Personally I run copSSH (version 1.4.2)as my SSH server package of choice on a Vista Ultimate desktop PC and WinSCP (version 4.0.2 beta) as my SFTP client on a Vista Ultimate laptop.
_________________
"When all else fails, read the instructions..."

Reply with quote

Shaman
Guest

RE

So ..
From my PC (WinXP) everything works fine, but from my NB (Vista) the server is refusing the connection. I thought the problem was my new router (dlink 624) but I'm using my old SMC 704vbr now. I never had to open any ports for SSH from my desktop pc.

I think this is either notebook or Vista related, and it's very weird

Reply with quote

Advertisement

Sooner Al
Joined:
Posts:
10
Location:
Norman, Oklahoma

Re: RE

Shaman wrote:

So ..
From my PC (WinXP) everything works fine, but from my NB (Vista) the server is refusing the connection. I thought the problem was my new router (dlink 624) but I'm using my old SMC 704vbr now. I never had to open any ports for SSH from my desktop pc.

I think this is either notebook or Vista related, and it's very weird

Anything in the event log on the notebook that may provide a clue?

Your right, you should not need to open any ports outbound on your router, notebook client or desktop client. That is why I was asking if your Vista PC was a client or server...
_________________
"When all else fails, read the instructions..."

Reply with quote

Shaman
Guest

Yes, I was talking about the client, sorry I forgot to mention.

. 2007-06-23 00:22:01.741 WinSCP Version 4.0.2 (Build 344) (OS 6.0.6000)
. 2007-06-23 00:22:01.741 Login time: 23 iunie 2007 00:22:01
. 2007-06-23 00:22:01.742 --------------------------------------------------------------------------
. 2007-06-23 00:22:01.742 Session name: ssh
. 2007-06-23 00:22:01.742 Host name: *.net (Port: 22)
. 2007-06-23 00:22:01.742 User name: * (Password: No, Key file: No)
. 2007-06-23 00:22:01.742 Tunnel: No
. 2007-06-23 00:22:01.742 Transfer Protocol: SFTP (SCP)
. 2007-06-23 00:22:01.742 Ping type: -, Ping interval: 30 sec; Timeout: 15 sec
. 2007-06-23 00:22:01.743 Proxy: none
. 2007-06-23 00:22:01.743 SSH protocol version: 2; Compression: No
. 2007-06-23 00:22:01.743 Agent forwarding: No; TIS/CryptoCard: No; KI: Yes; GSSAPI: No
. 2007-06-23 00:22:01.743 Ciphers: aes,blowfish,3des,WARN,des; Ssh2DES: No
. 2007-06-23 00:22:01.743 SSH Bugs: -,-,-,-,-,-,-,-
. 2007-06-23 00:22:01.743 SFTP Bugs: -,-,-
. 2007-06-23 00:22:01.743 Return code variable: Autodetect; Lookup user groups: Yes
. 2007-06-23 00:22:01.743 Shell: default, EOL: 0
. 2007-06-23 00:22:01.743 Clear aliases: Yes, Unset nat.vars: Yes, Resolve symlinks: Yes
. 2007-06-23 00:22:01.743 Alias LS: No, Ign LS warn: Yes, Scp1 Comp: No
. 2007-06-23 00:22:01.744 Local directory: default, Remote directory: home, Update: No, Cache: Yes
. 2007-06-23 00:22:01.744 Cache directory changes: Yes, Permanent: Yes
. 2007-06-23 00:22:01.744 DST mode: 1
. 2007-06-23 00:22:01.744 --------------------------------------------------------------------------
. 2007-06-23 00:22:01.802 Looking up host "*.net"
. 2007-06-23 00:22:02.034 Connecting to *.117 port 22
. 2007-06-23 00:22:03.308 Failed to connect to *.117: Network error: Connection refused
* 2007-06-23 00:22:03.324 (ESshFatal) Network error: Connection refused.

Anyway, can you point me to another good SSH client that works with Vista? Just to see if it's a Vista problem or Winscp on Vista issue. Thanks.

Reply with quote

Shaman
Guest

Edit : Winscp was working fine, it was just me using the wrong port (22 instead of 5522). Sooner Al thanks for your help.

Good job Martin, Winscp's the only (s)ftp client I use :)

Reply with quote

Advertisement

You can post new topics in this forum