filename problem when synchronizing: % gets changed to %25

Advertisement

eharley
Joined:
Posts:
1

filename problem when synchronizing: % gets changed to %25

hello,

Tried to search for this both on this forum and on google, but I wasn't able to find anything. I'm using
WinSCP version 3.8.2 (build 330), Norton Commander interface
and connecting via
SFTP (v3)
I have WinSCP running on Windows XP Pro.

Some files in the remote directory have the % character in the name. When I synchronize directories, it prompts me to copy the files over to my local directory. In the prompt (listing with all the checkboxes), the files come up with the correct name. However, when they are written to the local (NTFS) file system, all the % characters get changed to %25.

Does anyone else observe this, and is there anything I can do to work around it (outside of not using % in the filename or not synchronizing such files)? Please let me know if any additional information would be helpful for tracking this down.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,095
Location:
Prague, Czechia

Re: filename problem when synchronizing: % gets changed to %25

You can disable this in transfer settings.
_________________
Martin Prikryl

Reply with quote

eharley--
Guest

thanks for the help

OK, thanks for the help. Obviously this fixed my problem.

Kind of embarrassing that I missed something that was actually right there in transfer settings.

...in my defense :D the description says that it replaces special characters that can't appear in Windows filenames, so I didn't expect that to have anything to do with replacing the % character, which is permitted in Windows XP filenames. Maybe that's XP-specific and is retained for cross-Windows version compatibility? In any case, I should have tried it before.

Reply with quote

Advertisement

You can post new topics in this forum