Topic "Error while transferring binary file to remote ftp server"

Author Message
anand14
[View user's profile]

Joined: 2007-07-25
Posts: 2
Location: Baltimore, MD
Ok, I have read the FAQ (which is confusing by itself) and another post on the subject about this. I am sorry but I am going to ask a question relating to the timeout error during the ftp process.

I am using the command line tool (winscp.com) to negotiatate a file transfer to a remote host. I am getting an error while transferring binary files. The file extension ends in ".txt.gz" (gunzipped files from UNIX).

I am using the following command in my Perl script:
winscp.com /console /script=example.txt

I get an error message saying "Server has exceeded the 15 second timeout". The file I am trasferring in binary is only 2 KB! I tried to increase the timeout on the GUI to 60 seconds but the script defaults to 15 seconds.

I also tried using the "INI" option but it keeps asking for the host key and there is no option to enter it even thought the script asks for "Y" "N" or "Abort".

Also, if you try to change the timeout settings on the GUI, it wipes out the user id, password, host information for your SESSIONS.

Any tips, information will be appreciated.

Thanks!

-Anand
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
Please post a log file.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License