Forcing binary for all transfers of all my favorites

Advertisement

Mastakilla
Guest

Forcing binary for all transfers of all my favorites

Hello all,

I use Winscp a lot. I have around 50-100 favorites in my Winscp which all connect to hp-ux servers using SSH.

I recently discovered that Winscp, by default, screws up the unix new line characters by replacing them by windows new line characters.
This is because, depending on the extension of the file, Winscp transfers some files (including .sh scripts) in text mode.
By doing so, all unix new line characters are replaced by windows new line characters and the scripts stop working.

This is not very nice... but it is solvable...

When you go in the preferences of Winscp you can force Winscp to do ALL transfers in binary mode, which solves the above problem.

However, there is another problem...

Apparently this settings is saved per favorite (session) and, as you can imagine, I wouldn't like changing this option for all 50-100 of my favorites...
So I went looking where this setting is stored. I quickly found out all settings of Winscp are stored in the registry. However I couldn't find the registry key that stores the transfer mode for a session, so I can't modify it directly in the registry... :(

so my question is:
Does anyone know a way to easely modify the transfer mode for ALL my favorites in one easy action?

Thanks!

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,476
Location:
Prague, Czechia

Re: Forcing binary for all transfers of all my favorites

The setting is global, not per-session.
_________________
Martin Prikryl

Reply with quote

Mastakilla
Guest

weird

it seems like your right

is it possible that you need to close all winscp instances first after changing this setting, before it becomes active for all favorites?

but in any case it does seem to work now, thanks

nice program btw, although i do find it strange that a text transfer has to screw up the new line characters (filezilla does the same btw)

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,476
Location:
Prague, Czechia

Mastakilla wrote:

nice program btw, although i do find it strange that a text transfer has to screw up the new line characters (filezilla does the same btw)
That's what a text transfer is all about.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum