MS Office 2007 GRIEF!

Advertisement

ashish
Joined:
Posts:
4

MS Office 2007 GRIEF!

WinSCP has been coming along great....EXCEPT... with MS Office 2007 files. I always get the error - copying to remote side failed. I have gone through all threads and there is no solution. Please see my log and tell me where the problem is.


File: "/sdsdfsdfsd.doc"
Copying "/sdsdfsdfsd.doc" to local directory started.
Binary transfer mode selected.
Binary transfer mode selected.
Starting download of /sdsdfsdfsd.doc
TYPE I
200 Type set to I.
PORT 192,168,1,134,6,146
200 Port command successful.
RETR sdsdfsdfsd.doc
150 Opening data connection for sdsdfsdfsd.doc (22016 bytes).
226 Transfer ok
Download successful
TYPE I
200 Type set to I.
PORT 192,168,1,134,6,146
200 Port command successful.
RETR sdsdfsdfsd.doc
150 Opening data connection for sdsdfsdfsd.doc (22016 bytes).
226 Transfer ok
Download successful
[Background 1] Copying 1 files/directories to remote directory "/"
[Background 1] PrTime: Yes; PrRO: Yes; Rght: rw-r--r--; PrR: No (No); FnCs: N; RIC: 01; Resume: N (102400); CalcS: Yes; Mask:
[Background 1] TM: B; ClAr: No; ExclM(No):
[Background 1] AscM: *.*html; *.htm; *.txt; *.php; *.php3; *.cgi; *.c; *.cpp; *.h; *.pas; *.bas; *.tex; *.pl; .htaccess; *.xtml; *.css; *.cfg; *.ini; *.sh; *.xml
[Background 1] File: "C:\DOCUME~1\NewUser\LOCALS~1\Temp\scp47140\sdsdfsdfsd.doc"
[Background 1] Copying "C:\DOCUME~1\NewUser\LOCALS~1\Temp\scp47140\sdsdfsdfsd.doc" to remote directory started.
[Background 1] Binary transfer mode selected.
[Background 1] Starting upload of C:\DOCUME~1\NewUser\LOCALS~1\Temp\scp47140\sdsdfsdfsd.doc
[Background 1] TYPE I
[Background 1] 200 Type set to I.
[Background 1] PORT 192,168,1,134,6,149
[Background 1] 200 Port command successful.
[Background 1] Can't open file 'C:\DOCUME~1\NewUser\LOCALS~1\Temp\scp47140\sdsdfsdfsd.doc'.
[Background 1] Copying files to remote side failed.
[Background 1] Retrieving directory listing...
[Background 1] TYPE A
[Background 1] 200 Type set to A.
[Background 1] TYPE A
[Background 1] 200 Type set to A.
[Background 1] PORT 192,168,1,134,6,150
[Background 1] 200 Port command successful.
[Background 1] LIST -a
[Background 1] 200 Port command successful.
[Background 1] LIST -a
[Background 1] 150 Opening data connection for directory list.
[Background 1] 226 Transfer ok
[Background 1] Directory listing successful
[Background 1] (ECommand) Copying files to remote side failed.
[Background 1] Can't open file 'C:\DOCUME~1\NewUser\LOCALS~1\Temp\scp47140\sdsdfsdfsd.doc'.
[Background 1] Copying files to remote side failed.
[Background 1] Port command successful.
[Background 1] Port command successful.
Directory content loaded from cache.
[/b]

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,791
Location:
Prague, Czechia

Re: MS Office 2007 GRIEF!

Maybe you have the file opened at the time it is being uploaded?
_________________
Martin Prikryl

Reply with quote

ashish
Joined:
Posts:
4

No I dont. I can guarantee that any system will face this problem - I have tried it on 3 different systems (one ven vista).

Let me know if you want any further details. At this time, I have switched to WS FTP but I am regularly checking for updates.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,791
Location:
Prague, Czechia

I'll send you a debug version soon.
_________________
Martin Prikryl

Reply with quote

ashish
Joined:
Posts:
4

Update

Bo, your latest version takes care of MS word files. But the excel files are still doing that. What seems to be the problem?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,791
Location:
Prague, Czechia

Re: Update

ashish wrote:

Bo, your latest version takes care of MS word files. But the excel files are still doing that. What seems to be the problem?
Which latest? 4.0.4? It was not working in 4.0.3?
_________________
Martin Prikryl

Reply with quote

ashish
Joined:
Posts:
4

Re: Update

MS Word 2007 - working in 4.0.4.346
MS Excel 2007 - not working in 4.0.4.346.

Let me tell you the exact problem.
When WinSCP is in "EDIT on DOUBLE CLIK" mode option, and when the default editor for .xlsx files is MS Excel 2007, upon double clicking an excel file , I get the following error message:

Can't open file 'C:\DOCUME~1\NewUser\LOCALS~1\Temp\scp28421\Deadlines.xls'.
Copying files to remote side failed.
Port command successful.

Note that all I did at this point was double-click on the file. I have tested this on three different compuers with the same result. Now I was receiving the same error on older versions of WINSCP for MS WORD.


Now this problem is partially due to security measures that Microsoft has in place. But the bigger players like WS FTP and BITKINEX have found solutions around this problem. You appear to an out of the box thinker and I think you might be able to figure this out. Please fix this problem from the root! If you want more details/screenshots/explanations , just let me know. I really need for this to work and work right.

Thanks,
Ashish


martin wrote:

ashish wrote:

Bo, your latest version takes care of MS word files. But the excel files are still doing that. What seems to be the problem?
Which latest? 4.0.4? It was not working in 4.0.3?

Reply with quote

Advertisement

You can post new topics in this forum