ipv6 & vista & winscp 4.04

Advertisement

tpeland
Translator
Joined:
Posts:
12
Location:
Finland

ipv6 & vista & winscp 4.04

I did some usability tests using IPv6 and Windows Vista. Here are the results.

Winscp version: 4.04
System: Windows Vista Enterprise 64-bit
Using a hostname that has only ipv6 address as "host".

--sftp / sftp--
gethostbyname: unknown error <OK> <Reconnect>
Fix needed: upgrade the putty code to at least 0.59.

--ftp--
Connection - Internet protocol version - Auto (it is gray but still selected!)
=> Connection failed. <OK> <Reconnect>
Note: the result is exactly the same with IPv4 setting.

Connection - Internet protocol version - IPv6
=> Works but ignores "passive" setting and always uses "active" connection.
It prints info about "PORT" command depending the status of passive flag but reality is different. This end result is that only user with admin rights (to allow traffic through the firewall) is able to use ipv6 ftp.

There exists ftp-ipv6 implementations that don't have this problem.

<invalid links removed>

Unfortunately I really need a graphical sftp client. That is the only reason why I couldn't turn the local Windows Vista classroom into ipv6 only system. All the other programs that are needed (even the commercial ones) are ipv6 ready.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,809
Location:
Prague, Czechia

Re: ipv6 & vista & winscp 4.04

tpeland wrote:

--sftp / sftp--
gethostbyname: unknown error <OK> <Reconnect>
Fix needed: upgrade the putty code to at least 0.59.
Unfortunatelly there's not an 0.59 version with Kerberos patch available yet.

--ftp--
Connection - Internet protocol version - Auto (it is gray but still selected!)
Then it is "off".

Connection - Internet protocol version - IPv6
=> Works but ignores "passive" setting and always uses "active" connection.
It prints info about "PORT" command depending the status of passive flag but reality is different. This end result is that only user with admin rights (to allow traffic through the firewall) is able to use ipv6 ftp.
I'll check that.
_________________
Martin Prikryl

Reply with quote

tpeland
Translator
Joined:
Posts:
12
Location:
Finland

Re: ipv6 & vista & winscp 4.04

martin wrote:

tpeland wrote:


Fix needed: upgrade the putty code to at least 0.59.
Unfortunatelly there's not an 0.59 version with Kerberos patch available yet.

It just depends witch of the kerberos patches you are using.
There is one available for 0.60 at http://rc.quest.com/topics/putty/

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,809
Location:
Prague, Czechia

Re: ipv6 & vista & winscp 4.04

tpeland wrote:

It just depends witch of the kerberos patches you are using.
There is one available for 0.60 at http://rc.quest.com/topics/putty/
Thanks. I'll check it.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum