[HELP NEEDED] Scheduled task sync not working

Advertisement

Guest

[HELP NEEDED] Scheduled task sync not working

Hi
For some reason I cannot get the synchronization working. When I run the task it just gives me a quick flicker and then nothing - no log, nothing.. I have tried following the FAQ and this is my setup (below). If I add user@host in the command line, the script will run fine manually, but still nothing when I run it through the scheduler.

Task is pointing at:
c:\sync.bat

sync.bat looks like this:
winscp.exe /ini=user@host.ini /script=user@host.txt /log=user@host.log

The ini holds:
[Configuration\CDCache]
user@host=*lots of data*

[SshHostKeys]
rsa2@22:host=*lots of data*

[Configuration\Interface]
[Configuration\Logging]
[etc...]
bla
bla

[Sessions\user@host]
HostName=myserver.com
UserName=user
PublicKeyFile=*path to key*
FSProtocol=0
RemoteDirectory=*remote dir*

script.txt holds:
option batch continue
option confirm off
option synchdelete on
option transfer automatic
synchronize remote "local dir" "remote dir"
synchronize both "another local dir" "another remote dir"
exit

Am I missing something obvious here? I'm no computer wiz, so please help me get this going.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,300
Location:
Prague, Czechia

Re: [HELP NEEDED] Scheduled task sync not working

First hint: Command line refers to user@host.txt, while in the post you mention script.txt.
Second hint: Run the script from console window (cmd.exe), so that the output does not disappear and you can see any possible error message.
_________________
Martin Prikryl

Reply with quote

skarabe
Joined:
Posts:
4
Location:
Lund, SE

Hi prikryl
Thanks for the reply

I managed to get it working. What I had to do was to create a .bat file which calls the other .bat holding the winscp command. Really weird..

Maybe a path issue or something. Anyhow, It's working OK now!

Reply with quote

Advertisement

You can post new topics in this forum