Issue with Multiple WinSCP (4.0.7) Sessions with Tunneling

Advertisement

adamw
Joined:
Posts:
6
Location:
Utah

Issue with Multiple WinSCP (4.0.7) Sessions with Tunneling

Hi,

I did my best to search the forum, but was unable to find a note on this issue. If it has already been discussed, I apologize in advance.

I am using WinSCP 4.0.7 in Explorer mode. When I connect to a server via SFTP with tunneling, it works like a charm. If I add another session that uses SFTP to connect server not using tunneling, both sessions work fine. Now, if in place of the second session not using tunneling, I open an SFTP session with tunneling, WinSCP asks me to accept a key. After that, everything goes bonkers. The first session works fine, however, the second session either starts to work properly, then stops OR the second session acts like it's connected to the correct server, but in reality, it's connected the the first server. This happens if I go through the same tunnel server, or different tunnel servers.

Other than that, I continue to enjoy this project. WinSCP has made my life much easier... especially with tunneling.

Thanks!

Adam

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Issue with Multiple WinSCP (4.0.7) Sessions with Tunneling

Can you post a log files showing opening of the both sessions?
_________________
Martin Prikryl

Reply with quote

adamw
Joined:
Posts:
6
Location:
Utah

Re: Issue with Multiple WinSCP (4.0.7) Sessions with Tunneli

Okay, here are the logs.

<invalid hyperlink removed by admin>
<invalid hyperlink removed by admin>

Sorry, I needed to replace some sensitive information with *s as to conceal the company this affected. I had a look at the files and it appears in both cases, port 6000 is used. (My settings are set to Autoselect under tunneling.) Since 6000 is already in use during the first session, the second session's assignment must be ignored and it uses the tunnel from the first session... I would guess.

I suppose I could manually configure a different port for each session, but there are more than 40 servers that I connect to via tunnels. Having it dynamic would be a boon.

Once again, thanks for all your hard work and efforts!

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Issue with Multiple WinSCP (4.0.7) Sessions with Tunneli

Are you opening the second session in the same window or in new instance of WinSCP?
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Issue with Multiple WinSCP (4.0.7) Sessions with Tunneli

Thanks for your post. This issue is being tracked already.
_________________
Martin Prikryl

Reply with quote

Alex (not registered)
Guest

Re: Issue with Multiple WinSCP (4.0.7) Sessions with Tunneli

Hello!

Sorry for restarting an old topic, but it seems that this bug is still valid in version 4.2.9.

I have two servers (app01 and db01) behind one proxy server (proxy01). First, I can connect to any of those servers. But when I try to open a new connection to another server, I see that actually I am connected to the same server as in the first connection.

Here are logs:
<invalid hyperlink removed by admin> - first connection;
<invalid hyperlink removed by admin> - second connection.

These two files are similar except line 55.
In first file there is:
. 2011-01-24 12:53:50.455 [Tunnel] Opening forwarded connection to app01:22
In the second file this line is missing.

Best regards,
Alex

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Issue with Multiple WinSCP (4.0.7) Sessions with Tunneli

You are forcing 22 local tunnel port, which explain it. Keep Autoselect if possible. On the other hand WinSCP should warn you. Does it? If not, are you opening the two connections in the same instance of WinSCP or are you running two instances?
_________________
Martin Prikryl

Reply with quote

Alex (not registered)
Guest

Re: Issue with Multiple WinSCP (4.0.7) Sessions with Tunneli

martin wrote:

You are forcing 22 local tunnel port, which explain it. Keep Autoselect if possible. On the other hand WinSCP should warn you. Does it? If not, are you opening the two connections in the same instance of WinSCP or are you running two instances?

I use port 22 as server administrator has set firewall and only this port is open. I have not received any warnings. I tried both same instance and two separate instances.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Issue with Multiple WinSCP (4.0.7) Sessions with Tunneli

It's local port, so it won't get blocked by the firewall.
_________________
Martin Prikryl

Reply with quote

Alex (not registered)
Guest

Re: Issue with Multiple WinSCP (4.0.7) Sessions with Tunneli

martin wrote:

It's local port, so it won't get blocked by the firewall.
The problem is that administrator has set firewall not only on the proxy server, but also on each server inside the network.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Issue with Multiple WinSCP (4.0.7) Sessions with Tunneli

I still do not believe that they have blocked opening local port for another application running on very same server. It is just not possible IMHO. Have you tried it at all?

Reply with quote

Alex (not registered)
Guest

They blocked opening connections not on the same server, but between servers in the local network.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Alex (not registered) wrote:

They blocked opening connections not on the same server, but between servers in the local network.
That's what I'm saying. The port we talk about is for connecting two applications on the same server. Or in this case, even for connecting within the same application.
_________________
Martin Prikryl

Reply with quote

Alex (not registered)
Guest

I have moved to another WiFi network and now it works.

In previous network, symptoms were that if I set local tunnel port to autoselect, then I cannot connect. But when I set it to 22, then everything works fine. All other settings remained the same.

Sorry for disturbing you.

Reply with quote

Advertisement

You can post new topics in this forum