Passing options to 'synchronize' command does not work?

Advertisement

dzekyl
Guest

Passing options to 'synchronize' command does not work?

I'm trying to synchronize directories from a script, deleting remote files that no longer exist locally. I use the following command from a script (executed by winscp407.exe /console /script=myscript)

synchronize remote -delete d:\backup\test /home/jakob/backup

However, WinSCP does not pick the -delete flag and instead reports

"Too many parameters for command 'synchronize'"

I've tried to insert the '-delete' option at different locations with no success. If I try simply

synchronize remote -delete

I get

"Comparing '-delete' with '/home/jakob'..."

i.e. '-delete' is interpreted as a directory name, not as a switch.

The same operation performed using the GUI works. Also, the script works if the '-delete' switch is not used.

I'm using the SFTP protocol and WinSCP 4.07 on Windows Vista 32-bit.

Is this a bug or am I doing something wrong?

Thanks,
dzekyl

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,658
Location:
Prague, Czechia

Re: Passing options to 'synchronize' command does not work?

Switch -delete is supported since 4.1 beta only.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum