WinSCP took a misstake with Non-Ascii character.

Advertisement

MASA.H
Guest

WinSCP took a misstake with Non-Ascii character.

When I use "" in directory name, WinSCP recognized "" as "s". So, if I have a directory named "wei", WinSCP display as "weis" and try to serch directory "weis" not "wei". Same misstake happened at "〜". Is it a WinSCP's bug?

My Eviroment:
scp Server: OpenSSH4.5 on Fedora 7
client: WinSCP 4.1.0 on Windows XP

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,070
Location:
Prague, Czechia

Re: WinSCP took a misstake with Non-Ascii character.

Would this FAQ explain that?
_________________
Martin Prikryl

Reply with quote

MASA.H
Guest

I use SFTP-3 as file transfer protocol with "UTF-8 Encoding for Filenames" option. And the server use utf8 as file name encoding. Is there any wrong?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,070
Location:
Prague, Czechia

Do you have German as defalt local encoding (as described in the FAQ)?
_________________
Martin Prikryl

Reply with quote

MASA.H
Guest

>Also note that WinSCP is not an Unicode application. Hence it can display only characters that are present in default language code page of your workstation.

It's too bad. I use both Deutsche and Japanese for filename.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,070
Location:
Prague, Czechia

MASA.H wrote:

It's too bad. I use both Deutsche and Japanese for filename.
WinSCP cannot handle that :-(
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum