Terminal functionnality

Advertisement

Marc Meurrens
Guest

Terminal functionnality

I am since a long time a happy :D user of
WinSCP 2.3.0.146 under W2K.
While not strictly necessary (I have allways also
a PuTTY terminal :idea: opened for interactive command),
I found usefull the Terminal functionality
(CTRL-T , Home Black Icon) for many non-interactive
commands (such as compiling a table, immediately
after uploading its data, etc).
Unfortunately :cry: , I moved to WinXP
and I decided btw to download the latest version.
A fresh new from sunday Aug 24 2003: version 3.2.1.174 !!!
The "Home Black Icon" is still there, but inactive...
and it seems :?: that the Terminal functionnality
is not available anymore???
..
A change between 2.3 and 3.2 :?: a bug :?:
a problem with WinXP v. Win2K :?:

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,790
Location:
Prague, Czechia

Re: Terminal functionnality

It should work. Please make sure that you connect using SCP protocol. Terminal feature is not available with SFTP (see Supported protocols).
_________________
Martin Prikryl

Reply with quote

Meza
Guest

problem with the terminal

I opened a terminal window and executed a Ping...

eg
ping yahoo.co.uk

and it just continually filled the terminal screen repeating that ping every second, WinSCP locked up and there was no way I could quit it without CTRL+ALT+DEling

Any ideas?

Meza

Reply with quote

baltner@...
Guest

Terminal no longer works

When I first loaded WinSCP3 the terminal window (cntrl-T) worked great but now the option is grayed out. I updated to WinSCP3.5.6 to see if this would fix it but it hasn't. I did not knowlingly change any config. options. Any ideas?

Thanks,
Bruce Altner

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,790
Location:
Prague, Czechia

Re: problem with the terminal

Meza wrote:

I opened a terminal window and executed a Ping...

eg
ping yahoo.co.uk

and it just continually filled the terminal screen repeating that ping every second, WinSCP locked up and there was no way I could quit it without CTRL+ALT+DEling
On Terminal windows, there is warning:
"Do NOT execute commands that require user-input".

You may do for example:
"ping yahoo.co.uk -c 5"
to do only 5 attempts.
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,790
Location:
Prague, Czechia

Re: Terminal no longer works

baltner@hq.nasa.gov wrote:

When I first loaded WinSCP3 the terminal window (cntrl-T) worked great but now the option is grayed out. I updated to WinSCP3.5.6 to see if this would fix it but it hasn't. I did not knowlingly change any config. options. Any ideas?
Please read documentation:
https://winscp.net/eng/docs/protocols

Reply with quote

Advertisement

You can post new topics in this forum