Window always in 800x600 afer 4.0.x to 4.1.15 update

Advertisement

henning
Guest

Window always in 800x600 afer 4.0.x to 4.1.15 update

When starting WinSCP and opening a saved account, the window is always in 800x600 only. If I click the maximize button it gets even smaller, about 640x480 and only if I click the maximize button again, it is fullscreen like it was in 4.0.x

How can I have it open always in fullscreen like it was before? I saved the current session in fullscreen but it will open in 800x600 when started next time.

Also the editor window, if I double click a remote .txt file, opens in not fullscreen.

Windows 2000, all patches, Winscp 4.1.15 downloaded today. Removed 4.0.x via Windows Control-Panel, kept personal data, installed 4.1.5.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Window always in 800x600 afer 4.0.x to 4.1.15 update

Can you provide me your email address, so I can send you a debug version of WinSCP to track the problem? If you do not want to post the address here, you can send me an email. You will find it (if you log in) in my forum profile. Thanks.

What version were you using before?
_________________
Martin Prikryl

Reply with quote

Nina
Guest

Same problem here.

Using Windows 2000 SP4 German with all patches.
Using the standalone version of WinSCP.
Just exchanged the executable from 4.0.7 to 4.1.5.

Effect: After connection, the WindowParams are set to "-4;-4;841;704;2" as per registry.
The fullscreen flag is retained however, so I need to switch twice (from pseudo fullscreen to normal, and back) to get to real fullscreen.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

henning wrote:

Please send to auto443473@hushmail.com
I have sent you an email.
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Anyone, would try to find out in what version was the problem introduced?
I see it working in the 4.0.7.
So please try 4.1 thru 4.1.4 to check in what version the problem was introduced.
https://sourceforge.net/projects/winscp/files/WinSCP/

Also it looks like the problem exhibits itself on Windows 2000 only. Or does anyone have the problem on different OS?

Reply with quote

henning
Guest

Works as expected with 4.0.7 (tried with 4.0.7 renamed to winscp.exe in 4.1.5 install), windows are in full-screen.

Bug is there starting with 4.1 beta (next release after 4.0.7, tried with 4.1 renamed to winscp.exe in 4.1.5 install), windows are wrong sized.

Commander-Look, did never use Explorer.

Reply with quote

henning
Guest

Maybe it helps, that's what I do:

- Start WinSCP (no session) with main menu
- Start a saved session
- -> wrong window size
- Resize window two times to get fullscreen
- Close session with WinSCP still running
- HKEY_CURRENT_USER\Software\Martin Prikryl\WinSCP 2\Configuration\Interface\Commander\WindowParams
is set to (correct fullscreen for my case): -4;-4;1028;744;2
- Start another saved session
- -> correct window size = fullscreen!
- close other session
- exit WinSCP
- WindowParams still set to correct value

- Restart WinSCP (no session) with main menu
- WindowParams is read 6 times from registry in a row with SUCCESS (checked with RegMon from sysinternals.com)
- Start a saved session
- -> wrong window size

So the correct value is found and read but not used or can't be parsed or similar with 4.1

Reply with quote

Nina
Guest

Yes, seems to be introduced in 4.1.

I downloaded the 4.1.0 beta standalone version and just ran it from desktop.
Tested Explorer and Commander view.

Same effect: It seems to save the registry setting correctly, but ignores it on loading.


Tested with vanilla Windows 98 in Virtual PC, too:
* start WinSCP 4.1.0 standalone
* run a connection
* switch to fullscreen
* quit WinSCP
* start WinSCP
* loaded connection
* KABOOM -- fullscreen icon activated, but window set to smaller size, although INI file seems to contain correct values

=> No update from 4.0.7, fresh install!
=> No registry usage, only INI file as default!

Reply with quote

Nina
Guest

Just noticed another effect:

In 4.1.5, after the window has been sized wrongly, I do not need to click on the maximize button twice (to bring it to small size and back fullscreen), but instead it is faster to minimize the window and RESIZE it by clicking the taskbar entry twice -- then the window is resized correctly to fullscreen!

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Nina wrote:

Just noticed another effect:

In 4.1.5, after the window has been sized wrongly, I do not need to click on the maximize button twice (to bring it to small size and back fullscreen), but instead it is faster to minimize the window and RESIZE it by clicking the taskbar entry twice -- then the window is resized correctly to fullscreen!
Can you provide me your email address, so I can send you a debug version of WinSCP to track the problem? If you do not want to post the address here, you can send me an email. You will find it (if you log in) in my forum profile. Thanks.
_________________
Martin Prikryl

Reply with quote

bluegroper
Joined:
Posts:
5

I like most things about WinSCP, but this window size bug is a small pita.
Yes, using Windoze 2K.
Have shortcut to launch WinSCP, set to maximize, but it doesn't.
Needs clickety-clacks with desk rodent to get manually maximized.
Hope you can find and squash this insect.
Cheers

Reply with quote

Horst
Guest

bluegroper wrote:

... this window size bug is a small pita.
Yes, using Windoze 2K.

Yes it is. Still there also with 4.1.6 :( :shock: :(

Reply with quote

Advertisement

You can post new topics in this forum