WinSCP Connection Error with Linksys NSLU2

Advertisement

jkunze
Guest

WinSCP Connection Error with Linksys NSLU2

Hi,

I'm using WinSCP with a NSLU2 from Linksys. With version 4.0.7 it worked perfectly. But since I upgraded to version 4.1.5 it doesn't work anymore. When I log in, I get the Error Message:

Unexpected directory listing line 'total 8'.
Invalid rights description '[0mtotal '

I don't see any files in the listview. And if i enter 'ls' in the terminal window I get:

/$ ls
bin
dev
etc
home
initrd
lib
lost+found
media
mnt
opt
proc
root
sbin
share
srv
sys
tmp
usr
var


There seem's to be a charset problem or something.
The server and protol information are:


Remote system = Linux nslu2 2.6.21.7 #1 PREEMPT Mon Dec 24 23:12:24 UTC 2007 armv5teb unknown unknown GNU/Linux
Session protocol = SSH-2
SSH implementation = OpenSSH_4.6
Encryption algorithm = aes
Compression = No
File transfer protocol = SCP
------------------------------------------------------------
Server host key fingerprint
ssh-rsa 2048 xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx <- deleted this information
------------------------------------------------------------
Can change permissions = Yes
Can change owner/group = Yes
Can execute arbitrary command = Yes
Can create symlink/hardlink = Yes/Yes
Can lookup user groups = Yes
Can duplicate remote files = Yes
Can check available space = No
Can calculate file checksum = No
Native text (ASCII) mode transfers = No


I hope you can help me, because I like this piece of software, and use it for all my (S)FTP and SCP stuff. :P

Jens

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
32,114
Location:
Prague, Czechia

Re: WinSCP Connection Error with Linksys NSLU2

Can you post a log file both from 4.0.7 and 4.1.5?
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
32,114
Location:
Prague, Czechia

Thanks for the logs.
This bug has been added to tracker.

As a workaround you can use Listing command session option to specify ls with parameters to disable the coloring. Or you can use full path to ls to bypass the alias.

Of course the most correct solution would be to set coloring alias to ls only for interactive sessions.

Reply with quote

Advertisement

You can post new topics in this forum