Disable automatic reupload of files changed by "editor"

Advertisement

jhandt
Joined:
Posts:
1

Disable automatic reupload of files changed by "editor"

It would be nice to have an option to disable (or prompt for) the automatic re-upload of files that were changed with the "editor".

Reason: I set "explorer.exe" as editor, which seems to have mostly the effect that I can double click on all kind of stuff (e.g. pdf or MS word files) and they are downloaded into a temporary directory and then displayed with the according "default association" (e.g. acroread, MS word). In many cases the files will not be modified at all, but sometimes they are in an undesired way (e.g. if I open a word document and close it again without doing anything, there will always be some weird changes to the file according to some obscure MS masterplan). I do NOT want the changed files to be reuploaded in that case. So I would either like to disable that completely, or to get a prompt asking whether I want to reupload. (Remark: A prompt would kust be the behavior of the old SSHSecureShellClient-3.2.9)

Of course, if there is another/better way to achieve my goal (the behaviour described above) I am happy to hear it (I do not have any particular desire to use explorer.exe, and I do not know whether there is a dummy-program in XP that just opens a file with the according program).

The only workaround that comes to my mind is use the following .bat script as "editor" instead of explorer.exe:
- move file to another tempdir
- explorer.exe newposition\file
That might confuse winscp a bit (since the file vanishes), so instead of move I could make a copy.
In any case, this solution is obviously not very pretty.

The reupload-behavior choice "prompt/noprompt/disable" could also be made for each editor, then one could still have the reupload behavior for e.g. .tex files that are edited with a reliable editor that does not add unwanted changes.

Thanks to everyone involved for the nice program!

Josef

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,542
Location:
Prague, Czechia

Re: Disable automatic reupload of files changed by "editor"

I've never seen the behavior you describe, except with Excel. What version of Word are you using?

Note that you do not have to use "explorer.exe" as editor. You will get the same behavior if you use File(s) > Open. You can even set "open" as default double-click action in preferences. You can also try it this way, may it will work (it is bit different then if you use explorer.exe as editor).
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum