Topic "keepuptodate and preserve timestamp"

Author Message
Parke
[View user's profile]

Joined: 2008-08-28
Posts: 1
Location: Indianapolis, IN
Hello!
I am using WinSCP Version 4.1.6 (Build 412). I am using console and scripting to transfer via SCP using a keepuptodate function.

Initially, I was receiving the 'set permissions: not owner'. I wrote -nopermissions in the keepuptodate script to solve this. Then, I received the 'set times: not owner' prompt which I turned off 'Preserve timestamp'. (I exported the .ini file and am using /ini=c:\sysmod\winscp\winscp.ini to reference the config file.) I am still receiving the 'set times: now owner' prompt.

I have attempted option confirm off in the script file, but I'm not sure that applies to keepuptodate.

Is there any other way to turn off preserve timestamp? Also, if I do successfully remove this functionality wouldn't that prevent keepuptodate from checking if this file was actually updated?

Thank so much Martin!

~Parke~
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Parke wrote:
Also, if I do successfully remove this functionality wouldn't that prevent keepuptodate from checking if this file was actually updated?

Correct. It makes no sense to turn off preserve timestamps with keepuptodate.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License