Editor in 3.1.7 changes files from unix format to dos format

Advertisement

thedobc
Guest

Editor in 3.1.7 changes files from unix format to dos format

Editor in 3.1.7 changes edited files from unix LF's to dos CR/LF.

After editing files you have to run dos2unix on them

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Editor in 3.1.7 changes files from unix format to dos format

Only if you configure it to do so.
_________________
Martin Prikryl

Reply with quote

thedobc
Guest

Re: Editor in .1.7 changes files from unix format to dos format

martin wrote:

Only if you configure it to do so.
Sorry. I meant 4.1.7
I can't find where this is configured. I looked at every option I can see.

Never mind. I see in the docs;


The internal editor supports only Windows-format text files.

So I guess I will need to configure an external editor. But I don't remember having this problem until recently. I have been using WinSCP since the early 3.xx versions.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Editor in .1.7 changes files from unix format to dos format

You may have changed default transfer mode in WinSCP.
_________________
Martin Prikryl

Reply with quote

dandv
Guest

Same bug in 4.1.8 - editor saves CRLF no matter what

I'm encountering the same bug in 4.1.8. The internal editor will save the newlines in a file as CRLFs, no matter what. This does not involve any transfers. Simply edit a LF-separated file with the built-in editor, then save it. Notice that the linbreaks have been converted to CR/LF.

It does not matter, but I had the end-of-line characters set to "LF" in my Server Environment preferences.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Same bug in 4.1.8 - editor saves CRLF no matter what

dandv wrote:

I'm encountering the same bug in 4.1.8. The internal editor will save the newlines in a file as CRLFs, no matter what. This does not involve any transfers. Simply edit a LF-separated file with the built-in editor, then save it. Notice that the linbreaks have been converted to CR/LF.

It does not matter, but I had the end-of-line characters set to "LF" in my Server Environment preferences.
What protocol?
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: SFTP

dandv wrote:

The server protocol is SFTP with "Allow SCP fallback", but no transfer is ever taking place.
Are you editing local files or what?
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: SFTP

dandv wrote:

martin wrote:

Are you editing local files or what?

Yes, for example before transferring them.
Would be worth mentioning that initialy.
Well you are editing file on Windows, so WinSCP uses CRLF.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum