WinSCP and Character Set

Advertisement

Gerhard
Guest

WinSCP and Character Set

I'm using WinSCP to access my NAS. Samba is set up to use Western European character set CP1252 and the files copied to NAS via Samba are displayed correctly with all german special characters () in Windows Explorer.

Over a WinSCP connection I the special characters are not display correctly (as in a putty session).

Is there a way to define a character set in WinSCP ?

Thanks for your reply,
Gerhard

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,426
Location:
Prague, Czechia

Re: WinSCP and Character Set

Please read FAQ. If that does not help, come back.
_________________
Martin Prikryl

Reply with quote

Guest

Hi Martin,

Thanks for your reply. I've read the FAQ and tried to set "UTF-8 encoding" from Auto to On and Off, but filenames with special character are where still displayed wrong.

What can I do ?

Gerhard

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,426
Location:
Prague, Czechia

Does your server support UTF-8 at all?
_________________
Martin Prikryl

Reply with quote

Guest

martin wrote:

Does your server support UTF-8 at all?
Yes, I think so.
If I set putty to use UTF-8 the files are display correctly.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,426
Location:
Prague, Czechia

OK, more precisely: Does not FTP/SFTP server support UTF-8? BTW, which one do you use?
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum