Compatibility with WinSSHD

Advertisement

Guest

Compatibility with WinSSHD

Hi,
According to bitvise, WinSSHD should work with WinSCP: https://www.bitvise.com/winsshd-usage-faq.html

However, I'm running into problems even though I'm running the SCP session under the bash shell...I think. :D

Here's some log info:

. Shell: e:\cygwin\usr\bin\bash.exe, EOL: 0
. Local directory: C:\, Remote directory: f:\FTP, Update: No
. Clear aliases: Yes, Unset nat.vars: Yes
. Alias LS: No, Ign LS warn: Yes, Scp1 Comp: No

. Doing startup conversation with host (shell).
. Skipping host startup message (if any).
> echo "WinSCP: this is end-of-file:0"
< WinSCP: this is end-of-file:0
. Detecting variable containing return code of last command.
. Trying "$status".
> echo "$status" ; echo "WinSCP: this is end-of-file:0"
< WinSCP: this is end-of-file:0
. Trying "$?".
> echo "$?" ; echo "WinSCP: this is end-of-file:0"
< 0
< WinSCP: this is end-of-file:0
. Return code variable "$?" selected.
. Looking up current user groups.
> groups ; echo "WinSCP: this is end-of-file:$?"
! /usr/bin/bash: line 4: groups: command not found
< WinSCP: this is end-of-file:127

I can log in fine during an ssh session, but for some reason my WinSCP sessions can't find the commands. For some reason maybe the path's are not compatible between WinSSHD and WinSCP? Any help would be greatly appreciated!

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,671
Location:
Prague, Czechia

Re: Compatibility with WinSSHD

Anonymous wrote:

. Looking up current user groups.
> groups ; echo "WinSCP: this is end-of-file:$?"
! /usr/bin/bash: line 4: groups: command not found
< WinSCP: this is end-of-file:127
Have you tried to uncheck "Lookup user groups" option? (on Shell tab)
_________________
Martin Prikryl

Reply with quote

dcn19
Joined:
Posts:
1
Location:
Annapolis, MD

My original post only included a partial log. It wasn't just user group lookup that failed. Almost alll commands failed. I can supply the entire log if needed.

Thanks

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,671
Location:
Prague, Czechia

dcn19 wrote:

My original post only included a partial log. It wasn't just user group lookup that failed. Almost alll commands failed. I can supply the entire log if needed.
Please send me entire log

Reply with quote

Advertisement

You can post new topics in this forum