Bug in directory sync?

Advertisement

Schnulla
Joined:
Posts:
16

Bug in directory sync?

Hi there,

I'm using WinSCP v.4.1.7.
Please have a look on this screenshot:

screenshot (<invalid hyperlink removed by admin>) (edited by admin).

I have changed the copyright.png
image file (new date, different size).

Now I run the directory sync but WinSCP
tells me there are no differences?!

This is the first time I have noticed
such a bug (?) in diretory sync.

Please help!

Thanks a lot!

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Bug in directory sync?

What kind of synchronization are you using? What options? Screenshot of the synchronization dialog would be useful.
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

You are using remote synchronization. With it, only files newer in local directory are transfered to the remote one. While in your case the remote file is newer.

Depending on what you actually want to do, use local direction (to get the newer file to local directory) or mirror mode (to force older local file to remote directory).

Please read documentation.
_________________
Martin Prikryl

Reply with quote

Schnulla
Joined:
Posts:
16

Sorry the screenshot was wrong. The first time I
tried it was when I had checked "file size" AND
"file date" and he found no differences. But now
I know what was wrong, if I check both (size and date)
then WinSCP performs a logical AND of both predicates
and not a logical OR, right? So when I have only
file size checked it works :)

Thanks!

Reply with quote

Advertisement

You can post new topics in this forum