Having Trouble uploading to remote server HELP

Advertisement

tkilp
Joined:
Posts:
1

Having Trouble uploading to remote server HELP

I have wriiten a script that should upload my files from a directory on my local pc to a remote server. I run the script and it seems to work fine, but when i o to the WinSCP GUI to make sure it worked my files are not there: Here is the script I am running.
option batch on
# Disable overwrite confirmations that conflict with the previous
option confirm off
open 000-8143@ftpprd.tradebeam.com
# Change remote directory
cd /filer/webmethods/gate/sftp/000-8143/in
# Force binary mode transfer
option transfer binary
# upload file from the local directory c:\export\

put c:\export\*.txt
# Disconnect
close


This is what i see in WinSCP.com

C:\Documents and Settings\459769\My Documents\intergraph>cd C:\Program Files\Win
SCP\

C:\Program Files\WinSCP>winscp.com /console /script=example1.txt
batch on
confirm off
Searching for host...
Connecting to host...
Authenticating...
Using username "000-8143".
Authenticating with pre-entered password.
Authenticated.
Starting the session...
Reading remote directory...
Session started.
Active session: [1] 000-8143@ftpprd.tradebeam.com
/filer/webmethods/gate/sftp/000-8143/in
transfer binary
20090308TrackingFlatFile. | 0 KiB | 0.0 KiB/s | binary | 100%
TrackingFile_2009_02_24.t | 0 KiB | 0.0 KiB/s | binary | 100%
Session '000-8143@ftpprd.tradebeam.com' closed.
No session.
winscp>

ANy feedback would be greatlty appreciated :?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,658
Location:
Prague, Czechia

Re: Having Trouble uploading to remote server HELP

I do not see any problem with your script. Can you add "ls" command to the end to reveal actual content of the directory? BTW, what version of WinSCP are you using? What protocol?
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum