hiccups and progress reporting error

Advertisement

jamster43
Donor
Joined:
Posts:
7
Location:
USA

hiccups and progress reporting error

This is a great program! Thanks for building it. I donated just now and hope you get plenty of support! :D

Two items to address here:
1) How can I stop the program from reporting every time that a file/directory isn't found on the remote during a recursive copy to my PC? It stops the transfer and I don't care to know about it. I can look at the log if needed.
2) I just noticed that the progress % report in the onscreen logging is showing a very large negative number. I'm running two simultaneous copy jobs. It doesn't seem to effect anything except it makes the progress report useless.

The first item makes running a backup harder without intervention. The second item is not a big deal. Thanks!

PS: I originally posted this in the "Features" topic by mistake.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,252
Location:
Prague, Czechia

Re: hiccups and progress reporting error

jamster43 wrote:

1) How can I stop the program from reporting every time that a file/directory isn't found on the remote during a recursive copy to my PC? It stops the transfer and I don't care to know about it. I can look at the log if needed.
What does WinSCP report that? Can you post a full error message?
2) I just noticed that the progress % report in the onscreen logging is showing a very large negative number. I'm running two simultaneous copy jobs. It doesn't seem to effect anything except it makes the progress report useless.
I've never seen that. Do you refer to GUI progress window or progress in scripting console?
_________________
Martin Prikryl

Reply with quote

jamster43
Donor
Joined:
Posts:
7
Location:
USA

Re: hiccups and progress reporting error

martin wrote:

jamster43 wrote:

1) How can I stop the program from reporting every time that a file/directory isn't found on the remote during a recursive copy to my PC? It stops the transfer and I don't care to know about it. I can look at the log if needed.
What does WinSCP report that? Can you post a full error message?
2) I just noticed that the progress % report in the onscreen logging is showing a very large negative number. I'm running two simultaneous copy jobs. It doesn't seem to effect anything except it makes the progress report useless.
I've never seen that. Do you refer to GUI progress window or progress in scripting console?

I figured out how to make the job continue past error messages. The negative number in the % complete field shows up in the status window under the filesystem frames and in the pop-up window that shows up by default. I was doing a total BU from root from my iPhone to my PC. The negative number comes and goes. In one attempt it came and stayed. In other attempts it went away with the next file. I think they were audio files that were being moved so they were larger files.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,252
Location:
Prague, Czechia

Re: hiccups and progress reporting error

jamster43 wrote:

The negative number in the % complete field shows up in the status window under the filesystem frames and in the pop-up window that shows up by default. I was doing a total BU from root from my iPhone to my PC. The negative number comes and goes. In one attempt it came and stayed. In other attempts it went away with the next file. I think they were audio files that were being moved so they were larger files.
Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum