Topic "synchronize in script mode always says 'too many paramters'"

Author Message
jacksafro

Guest


If I try to use 'synchronize' in a script and run it with the command:

"c:\program files\winscp\winscp.com" /privatekey="c:\my\key\file" /script="c:\myscript.winscp"

It always tells me 'too many parameters for command synchronize'.

If I run the same series of commands in the winscp shell it works fine.

I have tried specifying the directories and not specifying the directories. I have made sure my paths contain no spaces or strange characters.

My script looks like this:

-----
echo on
batch on
confirm off
open scp://user@my.host:55000
cd "/site/data/mydata"
synchronize local
close
exit
-----

Why does the synchronize command work fine in the shell but not in the script?
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
I would expect some hidden character in the script file to cause the troubles. Can you try to manually type-in the script file from scratch? If that does not help, please email the the script file (compress/zip it before sending so it gets not modified by your email problems while sending).

You will find my address (if you log in) in my forum profile.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License