Command failed with return code 137

Advertisement

Guest
Guest

Command failed with return code 137

Hi,

This is an error between WinSCP 330 on WinXP and openssh3.7.1p2 on Solaris 8.

The WinSCP session start normally, i can see the files on the solaris box, but when i'm trying a copy from Solaris to XP , i've got the message "Command failed with return code 137".

When I'm trying to copy from XP to Solaris, I've got a timeout and then a message "external exception C0000029".

My solaris sshd works normally with sftp, scp and ssh but failed with WinSCP.
Nothing abnormal in the Solaris logs...

Can you please help me ?
Thanks

Guilhem

Reply with quote

Advertisement

Guest

Re: Command failed with return code 137

martin wrote:

Have you search the forum? Try theses topic. I suppose it should give you some idea:

Hi,

Well actually I did...
But the error code is not the same. 127 against 137.
And the PATH to get my ssh scp and sftp are well declared in .bashrc and .profile.
Moreover, my SSH is a Openssh-3.7.1p2, not a non-free one.

Guilhem

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Command failed with return code 137

I thought it was a typo (127 => 137). Please try WinSCP 3.3.1 beta build 189. With this version the "External exception" error should not happen. However it will not solve your problem. Can you post a log file?

Reply with quote

Guest

Re: Command failed with return code 137

Hi,

Actually, the beta version is working correctly in SFTP mode.

But when i'm trying the default SCP mode, the error code 137 is now on the both directions. The execption trouble has dispeared. The weird thing is that SCP works normally in console mode under Linux or Solaris and not with WinSCP...
I don't have any logs under Solaris from this problem...

Anyway, I'm able to transfer stuff between the 2 boxes. Great ! :o)

Guilhem

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Command failed with return code 137

Anonymous wrote:

The weird thing is that SCP works normally in console mode under Linux or Solaris and not with WinSCP...
In topic "WinSCP hangs on Xfer, PSCP works fine" I've wrote short explanation for this issue.

Reply with quote

Advertisement

You can post new topics in this forum