"Yes to All" for all background transfers

Advertisement

Ricardo
Donor
Ricardo avatar
Joined:
Posts:
108

"Yes to All" for all background transfers

After the new feature "Each selected file/directory can be optionally added individually to background transfer queue" was implemented, the "Yes to All" option used to replace files does not work for all queued files.
My question is: Would it be possible to implement an option "Yes to All" that works for all transfers in the queue?
It would be a good time-saver.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,262
Location:
Prague, Czechia

Re: "Yes to All" for all background transfers

You can disable confirmations for background transfer for the same effect.
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,262
Location:
Prague, Czechia

Ricardo wrote:

I like to have one confirmation... but not one for each file...
I do not understand.
_________________
Martin Prikryl

Reply with quote

Ricardo
Donor
Ricardo avatar
Joined:
Posts:
108

Ok. Again: That new feature will add each file as an individual item in the transfer queue. If every file will replace an existing one in the server, WSCP will ask for each file if they should be replaced or not. In this case, the "Yes to All" option will not work for all files queued in the transfer queue. Transferring a lot of files and answering the question for each one is very time-consuming.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,262
Location:
Prague, Czechia

I understand that. I gave you a solution for this. I just do not understand your objection agains the solution.
_________________
Martin Prikryl

Reply with quote

DanielB
Guest

Yes to All

I have the same problem, only worse.
First of all, what he means is that he wants to be asked for confirmation to overwrite files ONCE per transfer. Disabling confirmation globally means no confirmations whatsoever.

In my case, "yes to all" does not work at all. Is this a bug? It has worked for 2 or 3 versions now.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,262
Location:
Prague, Czechia

Re: Yes to All

DanielB wrote:

I have the same problem, only worse.
First of all, what he means is that he wants to be asked for confirmation to overwrite files ONCE per transfer. Disabling confirmation globally means no confirmations whatsoever.

In my case, "yes to all" does not work at all. Is this a bug? It has worked for 2 or 3 versions now.
What version are you using?
Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.

_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,262
Location:
Prague, Czechia

Re: Yes to All

I have selected 5 files in the local directory that already exists in the remote directory. I have disabled No confirmations for background transfers. I started upload on background. On the first file I got a overwrite confirmation prompts. I selected Yes to All. I didn't get any more prompts afterwards.

Using 5.0.7 beta with SFTP protocol.

Reply with quote

Advertisement

nikhilj1
Guest

Re: Yes to All

martin wrote:

I have selected 5 files in the local directory that already exists in the remote directory. I have disabled No confirmations for background transfers. I started upload on background. On the first file I got a overwrite confirmation prompts. I selected Yes to All. I didn't get any more prompts afterwards.

Using 5.0.7 beta with SFTP protocol.

This works only when "Transfer each file individually on background by default" has been unchecked.

I want that When it is checked and I get a prompt to Overwrite files, 'Yes to All' applies to all the files.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,262
Location:
Prague, Czechia

Re: Yes to All

nikhilj1 wrote:

This works only when "Transfer each file individually on background by default" has been unchecked.
That's true. Will consider improving this.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum