Can download, but not upload homepage Data.

Advertisement

Allyster
Joined:
Posts:
4

Can download, but not upload homepage Data.

Hey everyone,

Im using WinSCP to keep a Homepage up to date. I used to do this from my workplace PC, which worked perfectly, but when i tried to install and run it at home, i encountered a problem with synchronizing the files on the server. I was able to download them, but trying to overwrite the files on the server, i got several error messages, 1 each for every data i tried to upload.

Im running Windows XP Professional, WinSCP 4.1.9 (build 416) using SFTP-3.

I admit im kind of a noob concerning html, but since im using all the tools my workplace PC uses, i dont see the difference (and the problem).

I uploaded a screenshot: <invalid hyperlink removed by admin>

Its in German (duh!). In English it means "The File... cannot be overwritten. Press "Delete" ..... Common Mistake (Server should provide Error Message). Error Number: 4. Error Message from Remote Server: Failure. Request Number: 3."

Hope you guys can help.

Thanks in Advance.

Allyster

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,811
Location:
Prague, Czechia

Re: Can download, but not upload homepage Data.

Looks like you do not have a permissions to overwrite the file. Are you able to overwrite the same file at work? Do you use the same protocol (SFTP) at work? Also check if resume settings are the same.
_________________
Martin Prikryl

Reply with quote

Allyster
Joined:
Posts:
4

I got full writing permission at my PC at work, everything works fine. Im using SFTP-3 there as well, everything else seems to be standard preferences, too.
The error occurs on both my PCs at home btw, the laptop and the desktop PC. Both run over the router firewall, both have standard winSCP settings.
I`ll check out my Firewall settings as soon as Im at home, maybe thats the problem. Are there any special ports to be opened (TCP/UDP)?
And btw, do i need Putty to run the program?

Greetings

Ally

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,811
Location:
Prague, Czechia

Allyster wrote:

I got full writing permission at my PC at work, everything works fine.
I've meant permissions to the server.

I`ll check out my Firewall settings as soon as Im at home, maybe thats the problem. Are there any special ports to be opened (TCP/UDP)?
This is not relevant to the problem.

And btw, do i need Putty to run the program?
No.
_________________
Martin Prikryl

Reply with quote

Advertisement

Allyster
Joined:
Posts:
4

Hey Good Sir,

the problem got solved. I was told that I just forgot one dot in the directory which turned the read-only-permission into a write-permission. So WinSCP was flawless after all.

Thanks for your Time

Ally

Reply with quote

Advertisement

You can post new topics in this forum