Script exiting with "option batch continue" line added

Advertisement

_tibberous
Guest

Script exiting with "option batch continue" line added

I have this huge server sync script that was working good, but would get a message every few hours:

Operating system failed to create file x.filepart (or something like that)

Then it would let me press p to skip all, but skip all didn't work, and in a few hours the message would be back up. I added the line:

option batch continue

But now it exists after a few hours. What I think might be happening is that, it tries to make a tar.gz, but it takes too long. After 15 seconds, it normally prompts to abort -- but I think the batch option continue might be confirming the abort or killing the script.

Anyway - I changed the code so that "option batch continue" is used before the sync commands, and "option batch off" is used right after them. I'm testing it now, but does anyone have any other reasons it would terminate, or how I can stop it?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,227
Location:
Prague, Czechia

Re: Script exiting with "option batch continue" line added

I'm sorry, but there are too many assumptions in your post. It is hard to catch to something and deduce anything.

Operating system failed to create file x.filepart
The error message is not coming from WinSCP. Does it happen while downloading or uploading?

Can you post a log file showing some of the problems?
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum