4.2.3.494 Custom Commands / "Open Terminal" broken

Advertisement

Ricardo
Donor
Ricardo avatar
Joined:
Posts:
107

4.2.3.494 Custom Commands / "Open Terminal" broken

4.2.3.494 Custom Commands and the Open Terminal function are not working at all.
"Invalid access to memory" after I click any custom command or try to open terminal.

I'd say it is a critical bug. Need to revert to previous build.

[Vista+SP2 32bits]

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: 4.2.3.494 Custom Commands / "Open Terminal" broken

Thanks. I'll check it.
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: 4.2.3.494 Custom Commands / "Open Terminal" broken

This bug has been added to tracker.
_________________
Martin Prikryl

Reply with quote

Freitag
Freitag avatar
Joined:
Posts:
52

For me I do not get the error message, but PuTTY is opened to default window (as if no server or session information was passed)

I have a slightly modified version of PuTTY 0.60
http://jakub.kotrla.net/putty/

This one lets you use files to store you config info OR registry.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Freitag wrote:

For me I do not get the error message, but PuTTY is opened to default window (as if no server or session information was passed)

I have a slightly modified version of PuTTY 0.60
http://jakub.kotrla.net/putty/

This one lets you use files to store you config info OR registry.
This is unrelated. This topic is about the terminal console window of WinSCP.

Anyway, did it work in 4.2.2?
_________________
Martin Prikryl

Reply with quote

Freitag
Freitag avatar
Joined:
Posts:
52

martin wrote:

Freitag wrote:

For me I do not get the error message, but PuTTY is opened to default window (as if no server or session information was passed)

I have a slightly modified version of PuTTY 0.60
http://jakub.kotrla.net/putty/

This one lets you use files to store you config info OR registry.
This is unrelated. This topic is about the terminal console window of WinSCP.

Anyway, did it work in 4.2.2?

OK, I was causing my own problems here.

When I set the PuTTY application to "C:\Program Files\PuTTY\putty(ORIGINAL).exe", then the 'Open session in PuTTY' option works.


Also, I had mis-understood "open terminal" to mean generic shell, so I had not tried ^T option and only ^P option. Yes, I do also have the original bug listed in this thread.

Reply with quote

franc
Donor
franc avatar
Joined:
Posts:
46

Yes, it worked in 4.1.9 (stable release).

I have the same bug:

Invalid access to memory

when trying to do any 'Custom command'

WinSCP
Version 4.2.3 (Build 494)

Windows XP SP3

Amazing that it hasn't been remarked earlier.

Regards, franc

Reply with quote

Freitag
Freitag avatar
Joined:
Posts:
52

martin wrote:

Freitag wrote:

For me I do not get the error message, but PuTTY is opened to default window (as if no server or session information was passed)

I have a slightly modified version of PuTTY 0.60
http://jakub.kotrla.net/putty/

This one lets you use files to store you config info OR registry.
This is unrelated. This topic is about the terminal console window of WinSCP.

Anyway, did it work in 4.2.2?

I have an update on this. I was looking for where was best to place the fix - because it is PuTTY that is modified, that is also the best place for the fix (not here in WinSCP)

When WinSCP calls PuTTY it uses this command line

"C:\Program Files\PuTTY\putty.exe" -pw "PASSWORD" -load "WinSCP temporary session"

I tested and found that if I can change that to

"C:\Program Files\PuTTY\putty.exe" -pw "PASSWORD" -load "WinSCP temporary session [registry]"

That it will work.

So I am thinking that the fix could be that if the first confg file is not found, then an attempt to load one with " [registry]" appended on the config name might solve the problem.

I'll look in the modified PuTTY code later on and find if I can locate that area and make the change.

Reply with quote

macoy1978
Guest

open terminal in winscp is not working

my winscp is not working when i click open terminal it say invalid access to memory , im trying to installed cracked mywi and i cannot go through on open terminal. im using iphone 4 , 4.2.1 version. thanks need your advice. :(

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: open terminal in winscp is not working

macoy1978 wrote:

my winscp is not working when i click open terminal it say invalid access to memory , im trying to installed cracked mywi and i cannot go through on open terminal. im using iphone 4 , 4.2.1 version. thanks need your advice. :(
What version of WinSCP are you using? Have you tried the latest one?
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum