Topic "4.2.3 "Invalid access to memory" when executing Command"

Author Message
Freitag
[View user's profile]

Joined: 2007-10-25
Posts: 51
I'm using the Touch command.
I think it is a command that came with the installation.


Before it attempts the command it informs me that the current session does not support the command and a new session will have to be opened.

the same error happens for the Execute and Move commands.

the commands are defined thusly:
Execute
Description: &Execute
Custom command: "!"
Remote command

Touch
Description: &Touch
Custom command: touch "!"
Remote command
Apply to directories
Execute recursively

Move
Description: &Move
Custom command: mv "!" "!?&Move to:?!"
Remote command
Apply to directories


The remote server replies to uname -a with this.

SunOS SERVER_NAME_HERE 5.10 Generic_127111-09 sun4u sparc SUNW,Sun-Fire-V245


The same error happens when connecting to AIX. I don't have other server types here that I can test with, but I think the whole thing is not server related.

Custom commands that are not remote all work as they used to.

Local PC is XP SP 3 (Dell Optiplex GX-620)
emreyazici

Guest


I can confirm this bug. It seems not related with server side and it's not command specific, any custom command that requires seperate shell results with invalid access of memory. It seems to me that seperate shell session creation is problematic.

I also use 32bit XP SP3 on local PC, the previous release has no problem with the same local+remote environment.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
Thanks for your post. This bug is being tracked already.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License