3.4.1 garbles transferred files

Advertisement

Guest

3.4.1 garbles transferred files

Hi,

Let me be another to say how much I like WinSCP! It's great, easy to use and usually very reliable.

However, since 3.3.0, I haven't really had any luck with the new versions (not that I'm blaming you, I know you must work hard on the releases).

3.4 didn't transfer files smaller than 4K (which I see is fixed in 3.4.1) and now 3.4.1 garbles files.

I'm not sure if there is a difference based on file size, but I was transferring a theme.php file for phpNuke and it added a lot of @^ characters where there was only whitespace before.

Is that a tab character? I don't really remember.

If it helps, I'm using a Win98SE system, and transferring files to a Debian GNU/Linux system. I could list the SSH version #, but this problem seems to be directly related to 3.4.1.

3.3.0 works great for me, which is what I used to correctly upload the file.

Once again, thanks for GPL'ing such a great program for the community to use!

It is much appreciated.

Reply with quote

Advertisement

Guest

Re: 3.4.1 garbles transferred files

Anonymous wrote:


I'm not sure if there is a difference based on file size, but I was transferring a theme.php file for phpNuke and it added a lot of @^ characters where there was only whitespace before.

Is that a tab character? I don't really remember.


Actually, I just transferred a 200K text file and it is replacing text as well as whitespace; it's not differentiating (prob spelled wrong) between the two.

Bug :?:

:?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,426
Location:
Prague, Czechia

Re: 3.4.1 garbles transferred files

Thanks for letting me know. Shame on me :-( Hopefuly, I'll release fix today or tomorrow morning, I'll try, what I can. Both this and the 3.4 bug was caused by the SFTP performace improvement, I've introduced in 3.4. It was rather complicated change.
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,426
Location:
Prague, Czechia

Re: 3.4.1 garbles transferred files

I've forgot to add that the problem occurs only for text-mode transfers. So switch to binary and it should work fine. I hope that it also happens only for uploads. If you experience similar problem for downloads, please let me know ASAP. Thanks.
_________________
Martin Prikryl

Reply with quote

Guest

Re: 3.4.1 garbles transferred files

martin wrote:

I've forgot to add that the problem occurs only for text-mode transfers. So switch to binary and it should work fine. I hope that it also happens only for uploads. If you experience similar problem for downloads, please let me know ASAP. Thanks.

Yes, it seems that it only garbles on uploads (text mode, haven't tried binary), downloads seem fine (text mode).

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,426
Location:
Prague, Czechia

Re: 3.4.1 garbles transferred files

I have released version 3.4.2, which should fix the bug.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum