WinSCP fails with UTF-8 chars, FileZilla does not

Advertisement

Michael-O
Guest

WinSCP fails with UTF-8 chars, FileZilla does not

I am experiencing some problems with WinSCP 4.1.9 and 4.2.3. I run an server under ubuntu 8.04 LTS with openssh 4.7p1. Locale is de_DE.UTF-8. I have created a russian-named file and tried to retrieve it.

1. WinSCP fails to display the file name with UTF-8 auto and on but
2. sftp command line from another linux box works and
3. filezilla displays and transfers the file correcty.

This seems to be a problem with WinSCP then. Is there anything I could try about it?
If you need I could provide a shell account for testing.

Mike

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,540
Location:
Prague, Czechia

Re: WinSCP fails with UTF-8 chars, FileZilla does not

Please read FAQ. If that does not help, come back.
_________________
Martin Prikryl

Reply with quote

Michael-O
Guest

I tried the remark again and it did work out for cyrillic. Well, it's quite weak and not really a solution because I am limited to one language only.
Has this something to do with WinSCP's non-Unicode thing? FileZilla works natively.

Thanks

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,540
Location:
Prague, Czechia

Michael-O wrote:

Has this something to do with WinSCP's non-Unicode thing?
Yes it does. That's what the FAQ says.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum