Topic "SFTP server command line must be shorter than 50 characters"

Author Message
Frank Gruellich
[View user's profile]

Joined: 2009-10-05
Posts: 1
Hi,

this is my first post and bug report. Please be nice...

I'm using WinSCP 4.2.3 (Build 494) in Commander Style. I'm following the F.A.Q. how to use WinSCP with sudo. The OS running the SSH server is a standard CentOS 5.2 and its SFTP server is located in "/usr/libexec/openssh/sftp-server". The remote user I'm supposed to use is "someotheruser". So I'm trying to write
Code:
sudo -u someotheruser /usr/libexec/openssh/sftp-server
in Environment -> SFTP -> Protocol options -> SFTP server. Unfortunately, the input box accepts only up to 50 characters, so the input is truncated after ".../sftp-se". Of course, this does not work. If I create a shorter SFTP server path by symlinking /usr/bin/sftp-server -> /usr/libexec/openssh/sftp-server and use
Code:
sudo -u someotheruser /usr/bin/sftp-server
it works. If the username is shorter (eg. someuser) it works, too. However, both are not an option. Also usage without sudo is not possible, as it would break our audit trail. Is this a bug or (undocumented?) feature?

Thanks in advance.

Kind regards,
Frank.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24993
Location: Prague, Czechia
Thanks for your post. This issue has been added to tracker.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License