Synchronize and reconnects...

Advertisement

mrisch
Guest

Synchronize and reconnects...

One frustrating thing about synchronizing is that if the connection is broken (and it often is), the process starts over again from the beginning. Is there any way to track results so that synchronizing can pick up from where it left off?

Reply with quote

Advertisement

mrisch
Guest

Additional Information...

Not sure what additional information would help:
Ver. 4.2.3 (Build 494) - but the problem is the same on every version and has always been there. The server you connect to is irrelevant.

To recreate - select Commands|Synchronize... and set up synchronization of a remote site to the local directory. The settings are irrelevant.

As the program moves through the list of directories synchronizing, a connection may sometimes be lost for whatever reason. WinSCP asks if you want to reconnect (or does it automatically after a few seconds), but the synchronize... command doesn't pick up where you left off the way that transfers now pick up where they left off.

Instead, you have to re-rerun the synchronize command from the beginning. When trying to synchronize a large site, this is extremely problematic as it can take half an hour to compare all the directories, and having to re-run the whole thing from the beginning after 25 minutes can take all day.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Additional Information...

OK, thanks. I'll consider that.
_________________
Martin Prikryl

Reply with quote

mrisch
Guest

any updates?

Any chance this will be put in soon? The synchronize command is nearly useless without it for a large directory.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: any updates?

mrisch wrote:

Any chance this will be put in soon?
No, it is not easy to do.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum