Problems when I try to use WinSCP

Advertisement

peguy
Guest

Problems when I try to use WinSCP

Hi,

When I try to connect to my school's remote server with WinSCP, I get this error message:

Error listing directory "users/98/[mylogin]/"
Unexpected directory listing line "-rw-r--r-- 1 [mylogin] 112 Mar 23 2001 #cisp#".
Operation aborted

Until that, everything was working OK (Connecting...Authenticating...Starting the session...) but then suddenly it fails.

Is it possible to fix this?
(The remote server uses Unix - SunOS 5.5)

Thanks for your help!

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Problems when I try to use WinSCP

Problems when I try to use WinSCP
Very descriptive topic name :-(

Please next time search the forum. This was posted thousand times before already!

In short: WinSCP requires group name in directory listing. I would recommend you to try SFTP protocol, if possible.
_________________
Martin Prikryl

Reply with quote

peguy
Guest

Re: Problems when I try to use WinSCP

Sorry!

I actually had searched the forum, but I'm still clueless as to the solution... I'm not a very good english speaker and moreover I'm an art historian and literature student, not a computer specialist :) so the forum is quite a sort of exotic place for me.
So in short I kind-of-understand the nature of the problem, but is there a way to fix it?
Thanks a lot!

FS

Reply with quote

peguy
Guest

Re: Problems when I try to use WinSCP

Sorry!

I actually had searched the forum, but I'm still clueless as to the solution... I'm not a very good english speaker and moreover I'm an art historian and literature student, not a computer specialist :) so the forum is quite a sort of exotic place for me.
So in short I kind-of-understand the nature of the problem, but is there a way to fix it?
Thanks a lot!

FS

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Problems when I try to use WinSCP

OK. So I would recommend you to try two things. First you may select "SCP" tab on login dialog (you may need to check "Advanced options" check box to see it). There select "Enter" in "Shell" group. In the box to right, enter (or select from drop down list) "/bin/bash" (without quotes). Than try to connect again.

If this does not help, try to select "SFTP" protocol on "Session" tab (initial one).

If it still does not help, write again.

Also if there will be another error message displayed, after you change the settings, please post it here too.

I hope this helps.
_________________
Martin Prikryl

Reply with quote

peguy
Guest

No More Problems when I try to use WinSCP

martin wrote:



I hope this helps.

It does! Everything's perfect now, and the program is just GREAT: easy to use, fast and efficient.
Thanks a lot!

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Solution

For list of reasons WinSCP cannot parse directory listing and possible resolutions, see documentation.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum