Topic "winscp419 - copy remote to local failed at 4GB of data"

Author Message
anoncoward

Guest


(reposted, in case it was lost on end of 2GB file size wrapping report)

Copy of remote file to local directory failed on file reaching max unsigned 32bits.

Reports insufficient disk space to write file, asks what to do (abort, retry, skip, skip all, etc.)

destination drive has > 500GB available.

winscp 4.1.9, build 416 (per help about box)

The item was a foreground download, not queued.

add'l:
I presume this was via SCP connection. filesize after abort was 4,294,947,919 bytes (which is a rather strange 19377 less than 2^32.)

Glancing at code briefly, guessing it may be related to some of the 'int' parameters variables involved in the TStream/TMemoryStream/TFileStream/THandleStream family of objects (even though the seek() methods of at least TFileStream and THandleStream apparently support 64bit offsets, implying their internals probably should also - but a TMemoryStream is also used in TFileBuffer::WriteToStream(), which I expect may be the source of the error.)
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
SCP protocol does not allow more then 4GB. Please read documentation.
_________________
Martin Prikryl
anoncoward

Guest


prikryl wrote:
SCP protocol does not allow more then 4GB. Please read documentation.


I have now tried logging in with SFTP withOUT allowing SCP fallback, and I still get the same error.
anoncoward

Guest


<covering face in shame>

disk does indeed have plenty of space.

Unfortunately I did not realize filesystem was Fat32, which is apparently limited to 4GB max file size. <sigh>

sorry
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License