Prevent starting more than one sftp session

Advertisement

goetze
Guest

Prevent starting more than one sftp session

When editing a file with the internal editor and saving, the upload occurs on a new sftp session. Is there a way to configure WinSCP to use the existing sftp session instead (and never start a new session)?

Thanks,
--Steve Goetze

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,469
Location:
Prague, Czechia

Re: Prevent starting more than one sftp session

Not anymore. This feature was removed in WinSCP 4.1.
_________________
Martin Prikryl

Reply with quote

Kirk Wolf
Joined:
Posts:
5

Re: Prevent starting more than one sftp session

martin wrote:

Not anymore. This feature was removed in WinSCP 4.1.

I tried 4.0.7 and it seems to insist on starting a new SSH session when saving an edit window. I can find no option in Preferences/Transfer/Background that will disable this.

We have had many requests to get WinSCP working properly with IBM mainframes, and this feature is unfortunately the root of most of the problems - there are special "settings" (think "quote site ....") that are particular to MVS filesystems that can be set for a running session, and starting a new sftp session loses these. Is there an architectural reason that a single session will not work? The sftp packet architecture surely allows multiple transfers simultaneously on the same session. We might be willing to build our own patches if there were a chance that it would work. Any advise would be appreciated.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,469
Location:
Prague, Czechia

Re: Prevent starting more than one sftp session

Kirk Wolf wrote:

The sftp packet architecture surely allows multiple transfers simultaneously on the same session.
SFTP does, the other protocols do not. I'm not going to have special implementation for SFTP.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum