Losing Group and Others 'Write' Privileges on FTP to Remote Server

Advertisement

tlyman
Guest

Losing Group and Others 'Write' Privileges on FTP to Remote Server

No matter how we set the preferences, text files transferred from a local machine to a Unix server (Solaris 8.202) lose write privileges for Group and Other on the server. This results in an Octal 755 instead of 777.

It doesn't appear to be a security issue because within WinSCP I can right-click the transferred files on the server and reset the privileges correctly.

Any Ideas?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,070
Location:
Prague, Czechia

Re: Losing Group and Others 'Write' Privileges on FTP to Remote Server

SCP or SFTP? It works for binary transfers?
_________________
Martin Prikryl

Reply with quote

tlyman
Guest

Re: Losing Group and Others 'Write' Privileges on FTP to Remote Server

I've tried it with both binary and text and neither seems to work. We are using SFTP.

Thanks.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,070
Location:
Prague, Czechia

Re: Losing Group and Others 'Write' Privileges on FTP to Remote Server

OK, to make it short, I would like to see a log file. Is it possible?
_________________
Martin Prikryl

Reply with quote

phoenixweasel
Guest

Re: Losing Group and Others 'Write' Privileges on FTP to Remote Server

This is happening to me too. I'm running FreeBSD 4.9 with latest patches and OpenSSH 3.7.1 Portable.

If I use the command line sftp on the FreeBSD box, I am able to successfully chmod a file.

Here is a clip from my log:

Copying 1 files/directories to remote directory "/home/web-admin/htdocs/"
PrTime: Yes; PrRO: Yes; Rght: rw-rw----; PrR: Yes; FnCs: N; RIC: Yes; Resume: S (10240); CalcS: Yes
TM: M; AscM: *.*htm*; *.txt; *.php*; *.cgi; *.c; *.cpp; *.h; *.pas; *.bas; *.tex; *.pl; .htaccess; *.xtml; *.css; *.cfg; *.ini; *.sh; *.xml
File: "C:\Documents and Settings\weasel\Desktop\wcs time.txt"
Copying "C:\Documents and Settings\weasel\Desktop\wcs time.txt" to remote directory started.
Ascii transfer mode selected.
Opening remote file.
Type: SSH_FXP_OPEN, Size: 56, Number: 4355
Type: SSH_FXP_HANDLE, Size: 13, Number: 4355
Type: SSH_FXP_WRITE, Size: 169, Number: 4614
1 skipped SSH_FXP_WRITE, SSH_FXP_READ, SSH_FXP_DATA and SSH_FXP_STATUS packets.
Type: SSH_FXP_CLOSE, Size: 13, Number: 4868
Type: SSH_FXP_STATUS, Size: 24, Number: 4868
Status/error code: 0
Type: SSH_FXP_SETSTAT, Size: 56, Number: 5129
Type: SSH_FXP_STATUS, Size: 24, Number: 5129
Status/error code: 0
Listing directory "/home/web-admin/htdocs".
Type: SSH_FXP_OPENDIR, Size: 31, Number: 5387
Type: SSH_FXP_HANDLE, Size: 13, Number: 5387
Type: SSH_FXP_READDIR, Size: 13, Number: 5644
Type: SSH_FXP_NAME, Size: 446, Number: 5644
Type: SSH_FXP_READDIR, Size: 13, Number: 5900
Type: SSH_FXP_STATUS, Size: 28, Number: 5900
Status/error code: 1
Type: SSH_FXP_CLOSE, Size: 13, Number: 6148
Type: SSH_FXP_STATUS, Size: 24, Number: 6148
Status/error code: 0

Reply with quote

Advertisement

Guest

Re: Losing Group and Others 'Write' Privileges on FTP to Remote Server

I forgot to add one thing to the post above. If I select the files and use the "properties" button, it shows the 640 mode. If I click "w" for group (mode 660), it successfully changes it on the server.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,070
Location:
Prague, Czechia

Re: Losing Group and Others 'Write' Privileges on FTP to Remote Server

phoenixweasel wrote:

Copying 1 files/directories to remote directory "/home/web-admin/htdocs/"
PrTime: Yes; PrRO: Yes; Rght: rw-rw----; PrR: Yes; FnCs: N; RIC: Yes; Resume: S (10240); CalcS: Yes
TM: M; AscM: *.*htm*; *.txt; *.php*; *.cgi; *.c; *.cpp; *.h; *.pas; *.bas; *.tex; *.pl; .htaccess; *.xtml; *.css; *.cfg; *.ini; *.sh; *.xml
You have checked "Set permissions" (Rght: rw-rw----; PrR: Yes). You must uncheck this to preserve current permissions.
_________________
Martin Prikryl

Reply with quote

tlyman
Guest

Re: Losing Group and Others 'Write' Privileges on FTP to Remote Server

I unchecked the 'Set Permissions' checkbox and the resulting transferred file still has an octal 644. The log file is as follows:

. Copying 1 files/directories to remote directory "/in/"
. PrTime: Yes; PrRO: No; Rght: rwxrwxrwx; PrR: No; FnCs: N; RIC: Yes; Resume: S (10240)
. TM: M; AscM: *.*htm*; *.txt; *.php*; *.cgi; *.c; *.cpp; *.h; *.pas; *.bas; *.tex; *.pl; .htaccess; *.xtml; *.css; *.cfg; *.ini; *.sh; *.xml
. File: "C:\DOCS\Notepad\510104.txt"
. Copying "C:\DOCS\Notepad\510104.txt" to remote directory started.
. Ascii transfer mode selected.
. Opening remote file.
> Type: SSH_FXP_OPEN, Size: 31, Number: 10499
< Type: SSH_FXP_HANDLE, Size: 17, Number: 10499
> Type: SSH_FXP_WRITE, Size: 928, Number: 10758
< Status/error code: 0
. 1 skipped SSH_FXP_WRITE, SSH_FXP_READ and SSH_FXP_STATUS packets.
> Type: SSH_FXP_CLOSE, Size: 17, Number: 11012
< Type: SSH_FXP_STATUS, Size: 21, Number: 11012
< Status/error code: 0
> Type: SSH_FXP_SETSTAT, Size: 35, Number: 11273
< Type: SSH_FXP_STATUS, Size: 21, Number: 11273
< Status/error code: 0
. Listing directory "/in".
> Type: SSH_FXP_OPENDIR, Size: 12, Number: 11531
< Type: SSH_FXP_HANDLE, Size: 17, Number: 11531
> Type: SSH_FXP_READDIR, Size: 17, Number: 11788
< Type: SSH_FXP_NAME, Size: 432, Number: 11788
> Type: SSH_FXP_READDIR, Size: 17, Number: 12044
< Type: SSH_FXP_STATUS, Size: 22, Number: 12044
< Status/error code: 1
> Type: SSH_FXP_CLOSE, Size: 17, Number: 12292
< Type: SSH_FXP_STATUS, Size: 21, Number: 12292
< Status/error code: 0


Thanks in advance.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,070
Location:
Prague, Czechia

Re: Losing Group and Others 'Write' Privileges on FTP to Remote Server

OK, I'll check this. I'm now able to reproduce the behaviour. However currently I do not see any problem on my side that can cause this.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum